Issues with mercenaries

I have built the cart and claimed the free pack, but it will not let me open packs or complete the tutorial 2: we’re hiring! quest. I have 7 packs to open but once in the open pack area it’s just giving me an opening pack error and tells me to try again later.

Just wait a bit till the issue is solved.

They dont care, they only care for money

Can’t wait…been waiting forever for new Mercenaries content!! :smiley:

Bugs… They happen, you know — after virtually each patch nowadays, so something like this wasn’t totally unexpected. :grinning:

So true…but I really wanted to at least be able to buy a pack and get one new Merc in the training grounds!!

Apparently, they say one can get a legendary mercenary from the new quest chain, so maybe one should plan opening all the packs accordingly…

1 Like

It’s been resolved, so you can open some packs now:

Still not sure about that thing with legendary mercs or portaits from new story tasks, which I haven’t looked into yet. So far I’ve opened a few packs to get some mercs into training first, then we’ll see how it goes.

When I was playing mercenaries I upgraded thrall’s for the horde from 2-3,
it took my coins and did not upgrade the ability.
Same thing for Grommash Hellscream, blood fervor 3 to 4, took the coins and did not upgrade.

Seems like the Charge keyword is bugged, at least for Spawn of N’Zoth, they don’t attack at all.

1 Like

I have the same bug. Charge works with murlocs but not with Spawn of N’Zoth