Can't reroll quests, can't squelch


On OSX 10.14.6. After Tuesday’s patch, I can neither reroll quests nor squelch opponents. The little ‘x’ that’s usually present is no longer present. I haven’t rerolled since the patch.

Additionally, when I try to squelch someone, I can click on the squelch option, but nothing happens when I click it.

1 Like

same here on PC and Android.

Same here.
I’m stuck with 2 quests I can’t re-roll or complete and Squelch doesn’t work.

1 Like

Also unable to reroll quests on my iPhone or my iPad. Haven’t tried squelching.

Same here, can’t reroll quests!

I have the same problem

Same bug here. Please fix it!

PC and iphone user, neither of them will let me re-roll as well

I also am unable to re roll a quest of mine. I also tried to just complete it, however, it shows incomplete and will not reward me. Blizzard support was no help, said they cannot help with the quest reward, and just sent me to this link. Fantastic. Can we expect more of this with the new expansion as well?

1 Like

I have the exact same issues. No quest reroll and squelch just leaves popup bubble hanging and doesn’t squelch. On Android…Pixel 3a.

Идентичная проблема. Также нет отображения описания и названия карты факела из лиги исследователей на мага

Sent a ticket in on this issue, GM said to post here, so I am.


This needs to be fixed as it makes the game unplayable. Also and this is extremely important to consider now, an auto squelch option in the settings menu. Because some of us do not want to Emote at all, nor do we need people to spam “hello”, “opp”, and “thanks” every second.

Same here. I put in a ticket and the Game Master asked me to post it here. Always happy to help a Game Master.

So Weird! My main computer is an iMac and I have the same squelch bug, along with a serious lagging problem (even though my iMac is brand new and there was never an issue before). But, I also have a Dell laptop, and there’s no problem.

same. pc user, windows 10, can’t reroll quests, click squelch has no functionality, no response. this is %100 frequency, %100 repeatable - very surprised there is no response or fix for this yet.

they don’t want to put in an auto-squelch function to the game, but if i’m doing this myself every single match it becomes arbitrary, the same thing they don’t want to happen is happening anyway, and it only creates annoyance and inconvenience for the user.

Hey guys, did you see any of the dozens of other threads on the subject, including both sticky posts at the very top of this forum? Your issues are listed in there, and a fix is expected tomorrow or Tuesday:

It’s almost like this got posted before the blue sticky was posted!