Cannot complete the "Happy Hallows End" Quest

I have played a lot of arena matches and still can´t complete the quest. Thanks


I am also having this exact same problem.

Same here, no reply yet?

Same! I’ve played arena twice now and can’t complete the quest

The related event ended days ago. Have you played Arena games during the event or only in the last couple of days ?

i played it on “hallow’s end” as well as on other days, and it hasn’t worked. it also doesn’t say anywhere “play arena game on hallow’s end” just says “play a game in arena mode” and it’s still there

Same is happening to me.

Same problem. Tried on multiple computers, tried restarting, restarted blizzard launcher. I tried playing when I had a free ticket, and I tried paying for an arena run as well.


also cant complete this quest.

Same, nothing helps .

Same problema here, hope they will solve soon

To all: During the event, I played a Friendly Challenge with a friend, and for some reason that gave them credit to finish the quest. It was a “Wild” duel, and I think I am the one who issued the challenge, in case it matters. At the time, others had reported this in the forums.

So, this is a very long shot, but perhaps you can complete the quest this way.

As with all Legendary Quests, you can reroll it to free a spot in your log, but who would want to reroll a 200g quest?


Тоже не засчитывается квест. Что делать?

I have the same problem. I’ve played arena four times in a row. But the quest has been still showing in my list.

Same here.
Can’t complete the quest.

Anyone know if they are fixing the bug?

So after a week with this bug, blizz is not going to do nothing? We have one quest slot locked, and cant claim 200g, its frustating.

In case you guys missed it, there is a new post detailing the status of the bugs currently in game, and Monday or Tuesday, there will be a patch which, among other things, fixes this. Expand to see the whole post (the section I highlight below says it is fixed, but it is in the context of the patch next week).

I am sure a faster fix would have been welcome, but at least now we know that they do care and that they will fix this quest.

This works thank you!

Dec 11th and this bug still isn’t fixed for me. I’m ready to just reroll the quest because I’ve been waiting for them to fix it for so long.

There is a post in the Support section which says that rerolling is what you must do:
(I was surprised myself to learn of this post a few days ago. I wish it had been announced in a more obvious location.)