Xbox Diablo 4 server slam does not work

I pre-ordered the game when it was first advertised. I tried to load the updated server slam and I get the error message saying do you own this game or app, I need to know how to contact Blizzard entertainment and let them deal with it because how am I supposed to get the extra reward if I can’t play. It’s either that or I want a refund.

Okay I think I got it figured out or got it working at least. I had to reinstall reinstall reinstall reinstall

1 Like

Same issued here. Not able to start the game.

1 Like

We’re also having the same issue…I take it reinstall is the way to fix it?

I also have the Problem on XBox Series X.
Restart of the console and the router did not help.

1 Like

Same issue here, can’t open server slam, never had this issue during beta weekends

Yep, not great that we now have a 3hr Download/install wait when we already installed it

1 Like

Same issue ask if i own the game and ask if i have a dvd, i ordered the digital deluxe so yeah messed up xbox

3 reinstalls ? or 1 ?

1 reinstall but still got 2hrs 23mins install time to go… taking forever :sob:

Will run the 2nd reinstall over night. Its 10:30pm here

1 Like

I’ve been trying for almost 2 hours now. Is there any projection on when this problem will be fixed? This is worse than the first beta where I queued for 2 hour only to be kicked out of the game 5 minutes into it.

SOLUTION: Got to “Find in the store” and see your purchase options. If you see an option for “Get if FREE” click it and associate the new version to your account.

1 Like

well have changed my mac adress as well

I’m sorry you guys can’t get it squared away. I had to go to the Microsoft Xbox store and push install. I couldn’t do it from the shortcut icon I had to go directly to the store.

1 Like

I reinstalled and it says im too early lol so guess i don’t even get to play and i own ultimate version which it wont even let me do anything with

Same issue here but i don’t even have the option to install anymore! I pre-ordered ultimate way back and now i can’t even play… fix this please Blizzard!

Solved go to Microsoft store and get diablo 4

Same issue after re-downloading, and from store

Join the event, don t start the game the usually way.

Finally - after reinstalling for 2 days.
But now No more Boss Fight ist available.

It’s really unfortunate, that this problem did not even make it to Blizzards attention. Just saw the “known Problems” and it was not part of the Server Slam problems.