Invalid License Issues on PlayStation Consoles

The real question is consoles that are filesharing, can they get early access or is it solely the account its purchased on?

I just posted a new topic for a game share fix titled no joke game share fix with step by step instructions I am not a troll and will set up a live stream if need be to walk fellow players through it

Sorry it didn’t work. Full list of things I tried:

  1. Power cycled PS5. Full turn off in case if was something internal. This helps with general PS5 issues.
  2. Reset licenses. Warning, this may take a bit if you’ve been in the PSN ecosystem for a while.
  3. Downloaded free game Astro’s Playroom. Downloading ANYTHING from the PS store should work, as long as PSN sees it as a purchase. (Free purchase something else if you already have Astros Playroom!)

This seems to bang on the side of PSN and shake loose the Diablo license. The key is any purchase, even a free one.

Follow my post to start playing


Been playing for several hours now after doing the free game download trick. It actually works!

Our teams and our partners have done some work to help mitigate this issue.

If you’re still experiencing the licensing issue, we ask that you provide as much detail as possible which leads to the error as we continue to work on this with our partners.


I am still having issues. I have a ps5 account, no game share, I have linked it to my bnet account, everything seems linked correctly. I purchased the game through playstation store. Originally I purchased the standard edition and upgraded later to ultimate to play early. I continually get “Unable to find a valid license for Diablo IV. (Code 315306)”.

Hours ago, I was able to get in briefly after trying several of the tricks listed in this forum (I downloaded a free ps+ game). I got kicked out after 15 minutes stating the license could not be validated. Since then, nothing has worked. I’ve tried:

  1. Power cycle.
  2. Reinstall multiple times.
  3. Restore licenses.
  4. Switch back and forth between offline play (currently off)
  5. Purchase in game currency (platinum twice via ps store, I can see the purchase in my txn history in linked bnet account)
  6. Download multiple free games that count as purchases.

Nothing is working, I just get the same license error.

FWIW, I think the unique thing vs. other people is buying standard, then upgrading to ultimate, then linking a bnet account. Perhaps the license is incorrect cause it’s trying to draw it from my bnet account that’s linked vs. the ps5 purchased license? Or maybe it’s sending the “standard” edition license originally purchased vs. the upgraded ultimate?

If I look at my ps game collection I have two diablo versions “standard” and “ultimate”.


I have the ultimate version of Diablo IV on my PS5.
Bought it since closed beta.

The game itself on PS5 - I launched on another PS5 account because I had previously linked my bnet account there.

Now, I always get a license error, although during all beta tests I played without problems according to this scheme


Hey PezRadar,

I’m still waiting for an official response regarding users who bought 2 or more copies of the game expecting to play it with their significant other.

Copy 1 of Ulitimate edition bought from BNet
Copy 2 of Ultimate edition bought from PS Store linked to the same BNet

Now my wife has to use another Playstation Store ID + BNet account to play with me, but since gamesharing doesn’t work, she can’t play with me even if we bought 2 copies of the ultimate edition.

I would really appreciate someone from your team can comment about this.


Seems if you have multiple PS5’s you can only play it on one. Works fine on one, nothing but license error on the other.

Also my kid can’t play it on his account on my PS5. So no to family sharing either. Typical scammy Actiblizzard


Game sharing xbox seris s, uninstalled multiple times, reatared console 3 times, restarted internet.

Asked for a refund. 5 hours after the launch I was still playing alone as my friends can’t log in because of that issue. There’s nothing we haven’t tried even buying ingame curency, resetting, updating, or downloading another game. We’ll see on official release date how things evolved. Best luck to you all


Feel free to add me on PSN @ Bigsxywitglasses if you need help with a GameShare work around or peep my step by step topic No joke game share fix!

I am still experiencing the missing valid license error code 315306. I bought the deluxe edition on PlayStation a while ago, and have been trying to log in all day. I was briefly able to log in earlier but realized I had my PSN connected to my wrong account, so I corrected that on my pc, and linked the correct account and restarted my game to update my account link, but after closing the game I was unable to get in. For the last few hours I can open the game on PlayStation, pas s through the queue, just to see the warning message that there isn’t a valid license.


Just post a link to the refunds. I paid for early access and it won’t even let me play.


  • I am able to log in on PS5 as the main account on the console.
  • My spouse is not able to log in on their own with their account on the same console. They get the invalid license error.
  • However, when joining via couch co-op, they are able to log in because I am already in the game.
  • BUT they don’t have a character that is past the prologue so they aren’t able to play.
  • They would need to log in on their own to do that.

Been trying for nearly 5hrs on Xbox series S and I’ve done everything. I just can’t get past the log in and I don’t even have a have a que time anymore, it just immediately says unable to find a valid license for Diablo 4. So weird because my girlfriend plays right night to me, on Xbox as well and she has no problems at all. She’s logged in and out perfectly fine multiple times.

1 Like

I found a workaround. Click the 3 dots next to the play game button, go to view product, go down to Add-ons, and buy crypt hunter pack. This allowed me to get in instantly.

You should be good to go from there : Blizzard Support

IT worked for me thanks alot