Game Crashing specifically after patch 1.0.3 (June 27th) (Addressed with Patch)

Game just randomly crashes with no visible issues before crashing. Started happening after June 27th patch was applied.


Same here ever since the update today on June 27th my game crashes about every 5 minutes or so. Doesn’t seem to be anything in particular either. Just random crashes out of nowhere. The game will just close with no lag spikes or latency issues prior. Also gave me a BSOD the last time I tried.

PC Specs-
RTX 2080 Super, i7 9700k, 16GB RAM
1440p 160hz monitor
I would also like to add that my CPU is OC’d in case anyone else’s is as well

I’ve tried different GPU drivers, turning off my CPU’s OC, turning all my settings to low, deleting my GPU cache, re-installing the game(even on another ssd), scan and repair tool, limiting my fps, turning off/on v-sync and DLSS. Nothing seems to fix it

If its any help I was getting the fenris error

(UPDATE 6/30)
So I ended up trying to remove my CPU’s OC again today as a last ditch effort in being able to play. And I can say after doing so I was able to play for 6 hours with ZERO crashes. I just went and set everything back to factory settings in my BIOS. Hope this helps someone else too


Getting the same thing here. Before the patch I had to have the “limit cutscene fps” option enabled or else it would crash every few minutes. Since the patch, it crashes just like it did in the past but none of my settings have changed.

1 Like

I don’t think I’ve crashed a single time (the game locked a couple times in cutscenes during story before limiting fps) playing from release up until todays patch and now I’ve crashed between 5 and 10 times in 4,5 hours.

Edit: For clarity, I’ve not been grinding that hard for those 4,5 hours because I crashed in the first three NM dungeons I tried, so the number of crashes would probably be a lot higher if I was actually GAMING.

Also happening to me. No crashes until todays patch and its happening SO frequently. Upwards of four times in an hour.


same here constantly with no reason why?


SAME PROBLEM, STARTED TODAY!!! No troubleshooting seems to fix it


How are you all crashing?

BSOD? Black Screen with sound? Full shutdown? Booted to desktop?

Just curious to see if we might all be experiencing similar, or different crashes. They aren’t all the same.

1 Like

Game just straight crashes and I go straight back to the desktop. Says an unexpected error has occurred and give me a code. Time varies on how it crashes. This issue happened to me back during the beta. But ever since the full release, I had no issues until this patch.


Game crashes like 5-10 times an hour since patch. Unexpected error with code. Mostly while standing still in town or at the end of a NM dungeon.

9384C223-FD3A-4B71-9742-F381803C5B08 error code


same. i am experiencing the same thing…fricken sucks…imagine not doing a QA on this patch before they put it out…

1 Like

Yeah bro same here, never have issues with crashes and after the update today it crashes from nowhere and i dont now what to do

Same. Unexpected error with code:


The code changes everytime, so I doubt that matters. Last time I had crashes like this was in the first beta. They fixed it during second beta by adding that limit cutscenes option but, since the patch, it just crashes regardless of what options I have enabled/disabled.

Same here.

Crashed 3 times, all 3 during Helltides. No blue screen, but the Blizzard ‘bug report’ window opens. Ran ‘scan and repair’. No issues.

Never had the game crash until today after patch.

I can’t play like this.


Same here.

Had problems with constant crashes before, but now it’s unplayable. It crashes my whole WINDOWS to the blue screen with the “Your PC ran into a problem, we will restart it for you.”

Hmm I just go from smooth gameplay to a Black Screen with game sound still running. Have to hard boot, and then re-enable my GPU. No error messages that I can see due to monitor being blacked out.

Looks like there are multiple issues here.

I was rock solid from Beta to Hotfix 10, then this started.

1 Like

It’s happening to me too, I’ve never had any problems until today, after the patch it started crashing all the time

How extraordinary fantastic and wonderful it is, to have to install the patch to be able to play the game.
Only to discover that the patch might have botched it all.
No matter, Blizzard got our money, so they come out on top in the end after all.


I’m having the same issue. Happened in a Helltide, in Kyovashad, right after a nightmare dungeon. I never had a issue with the game crashing before this patch.

EDIT: disabled my VPN, same result. Crashes to desktop and latest error 666528E9-72D4-41E0-A778-F9B54D08A2C7. I just killed the boss in a nightmare dungeon and was just going through my inventory and crashed.

1 Like

For me, it’s both BSOD and Booted to desktop