Flickering item stats popups

I got multiple posts about this never got addressed by Blizzard, It’s 1.1.3 now and has been happening since 1.1.1 very sad. been on POE since 1.1.1 lol Rip diablo.

Same thing is happening for me …very frustating… a big part of the game is comparing items… and you get distractet to an anoying level…

Yes it’s so f’ing annoying dealing with comparing stats now with this blinking bs its getting me dizzy, this has been happening day 1 of seasons and they still havent fixed it go figure.

1 Like

course not we need a new dev team. I’m sorry but it’s true.

1 Like


It did work for me. U have to disable it , apply the changes, enable it and apply the changes again. Unchecking and checking the box only wont work. And do it for both ; advanced tooltip and advanced compare.

Can confirm doing it this way worked for me. Disable, apply. then re-enable and apply.

The same happens for me. I entirely stopped playing season 1 because of this issue. I’m glad that the trick with the tooltip option can fix it temporarily. It is still such a bummer a company like blizzard will not attend to a bug like this.

Started happening this season for me. Looks like an ongoing issue that needs to be resolved.

Same issue. Incredible… can’t play like that. I don’t get why Blizzard have not replied or explained this issue.

same for me too, it has been like this since the mid-end of season 1, i hope its fixed on season 2, but its not :(, this is really the only bad thing i can find on season 2 now, the game is actually much more fun on season 2 than season 1 :frowning:

1 Like

getting this bug since day 1 of season 2 (didn’t play the S1, so idk if it was happening before) its really anoying


I have the same problem been unable to find a fix.

1 Like

Up same problem… Blizzard fix this cancerous bug !

Fixed it for me, at least short term can’t say how long it’ll last. Thanks.

Edit: Only for the very short term sadly.

I might be wrong, since I havent tested it for very long. But the “Disable and Re-enable Tooltip Compare & Information-fix” wasnt working for me as well. So I toggled the Comparison in my Equipment-Stash on and off by hovering over an item and pressing Shift twice. Closed Inventory and opened it again and it`s fine for now.

Might be some issue if you close your inventory while compare items or something that bricks it? Anyway its super annoying when you try to see which items you want to vendor…

is it on their todo list to fix because i start getting issues by checking my inventory legendary items when they flicker and i cant realy compare the stats and have to wear the items to see …

Happening to me as well. Nice to see this has been an issue for almost 3 months without a single peep from Blizzard on if they’re looking into it.

1 Like

Same has been happening to me since patch 1.1. I haven’t been able to find any work around or reason for it scouring the internet. Just want to bump this and keep it alive; I see there are several closed down threads for the same issue.

1 Like

Same here since patch 1.1 Discrpition sometimes really not readable cause of this bug. For me its only above World Tier II.

Bumping this since the issue is still present as of 4 Nov. Both me and my bf have the bug. Extremely annoying.

me too me too me too
frustrating frustrating frustrating
pls hotfix pls hotfix pls hotfix