Bug dungeon Mithering Descent (threads of envy quest)

Got the same problem, it still shows up in blue. But I don’t remember if I actually completed the quest or if I should go there and kill the boss (now I can’t even because of the bug, invincible boss).

Same issue here. I think I remember the quest complete celebration played after clearing it the first time, but the icon never vanished and going there again will have the invincible boss at the end of it… Hopefully this get fixed in an upcoming patch…

Still less annoying that the quest in the desert where the go into the cave to kill the barbarians / cannibals and the gal at the start does her speech but doesn’t usually go to attack the wall and trigger the proper assault in the cave… Swear it took me 17 reloads of the cave at various times till it magically worked and the chick and her troops actually went to the barricade and destroyed it… Otherwise I would never have gotten the fury against fate achievement…

1 Like

Mortiferius, I had the same problem with that quest too. But I read somewhere that you should clear the event outside, then enter the dungeon fast, then start the conversation, and then run towards the barricade fast before the conversation with the npc was over :slight_smile:

This problem bothers me as well. Mithering Descent is blue, however there is no quest npc at Enetral Watch.

1 Like

This is still an issue on 6/12

Cleared the event and it didn’t fix the problem for me. Still took me like 5 tries after that till it somehow magically worked on a run where the event was still running when I entered.

I think what caused it the first time was me rushing into the fight while she was doing her speech and wiping out wave one before he speech was done… For som reason it took her 17 subsequent attempts to recover from that affront -_-

Still bugged as of June 16, 2023.

Same bugged still, does anyone else have 46/47 done and this is blue still? I’ve re-tracked every quest and spend like 30 mins farming each drop again just to check no luck.

1 Like

I have the same problem, 46/47 and the dungeon is still open. Im sure that i finished all quests.

Same issue as everyone else; quest is finished but the bugged quest dungeon icon is on my map with a bugged quest boss inside the dungeon that’s completely invincible.

Same here. Questline is done, but the dungeon still exist. Strange.

Same here, just ran it thinking it might have been one with a quest but the icon wasn’t showing up. Got to the end and went “oh wait I remember doing this!”.

still an issue 6/20 - invincible chick on a tree. i’m going around trying to find any quests, i don’t understand where people are eventually finding their missing quests. i can’t seem to find any of the ones i’m missing. i found this thread because i thought maybe this dungeon was a quest that is keeping me from finalizing my quests in scosglen but i guess not.


Blue post? Community mod? Response? Really would like to finish my achievements for quests 2 weeks in now


Same issue here. An answer would be appreciated.

Same issue here. The dungeon appears in blue. When I enter it, at the end, there is an immune Sodden Effigy.

Same issue. Still bugged for me as well. Silly invincible sodden effigy.

Same issue here - dungoen is still blue and the mob at the end is invincible to damage. Pretty sure this is my last quest for this area as I’ve checked for all the “hidden” quests and still at 46/47

Same issue here, finished the quest a long time ago, but the dungeon still remains on the map.

blizzard how’s this still an issue?

you had beta tests, pre ordering, and two weeks of play and the quest is still bugged.