A Sodden Pact Bugged

Quest is bugged, stuck on 4/5. Even found a map online of where they should be, they are just not there. Logged out, still havent spawned. Will keep checking, but I am assuming this is bugged somehow.


I’m having the same issue.

I was able to find all of them.

I’m bugged at the last stage of the quest which asks me to speak with Roina, but Roina isn’t at the place where she’s supposed to be, and where she is I can’t interact with her.

I got it fixed by using town portal and coming back.


Same here. Stuck at 4/5 for me, the last hair just don’t spawn. I checked the quest walkthrough videos on YT, and checked all 5 locations of the 5 hairs - the place where the last one for me should spawn, it doesn’t. Tried exiting to the menu, exiting the game, teleporting to other regions and back, waiting few hours - nothing helps.

1 Like

If you are stuck on finding sodden growths, only 5 spawn when you start the quest but they can be in a lot of different places. All the guides I found online only show 5 places, but its random.

I’m stuck at 4/5 as well. I’ve been searching for the last one for a good 30 minutes. I’d say it’s bugged and doesn’t exist.
And even if it does exist somewhere, it’s really poor quest design if you have to search that long to complete it.

And as far as anyone knows, up until this day, the hero is till searching for his last hair…

1 Like

Same, teleporting didnt work for me

Thought I was crazy or blind, spending an hour running around looking for that last sodden growth, but apparently the one or two that are supposed to be on the beach just do not spawn.

i only found ONE of them. logged out and back in over several days. never seen another one

Getting stuck at 4/5. Tried to re-log several times, dropped the quest, same thing. Several others were there as well, running around like I was looking for the quest item. I have to assume that they as well had the same bug.

One of the main issues that seems tied to this is many NPC’s that should be activating into combat just stand there and since they do not activate it seems it is blocking triggers for things to update.

Example in “watery Sinkhole” an adjacent cellar and 2 of the mobs remain “Twitchy” not activating and the mini-instance does not complete. It seems a shame that a company like Blizzard seems to have employees coding, “hooks” that never trigger.

I get it new games release with bugs but these seem to be obvious triggers missed in “Alpha” that where fully ignored.

1 Like

I’m having this issue right now i just lost 40min of my life

1 Like

I am stuck at 4/5 myself.

Same here… stuck at 4/5… some on the beach doesn’t spawn…

Stuck 4/5 please help blizzard. :sob:

Update: Still bugged

my fifth showed in the small alcove to the right of the top location showed on the location map guides. hope this helps

Same here… stuck at 4/5. Checked a guide and all 4 locations I’ve found check out. The 5th location has nothing in my instance… Tried multiple times now

Same for me. 4/5. Relogged, tried to abandon the quest and start again, teleported to other locations and back. Nothing helps…

people are confusing completing all 5 hairs but not getting roina to get to the last part of teh beach vs not able to find the last piece.

Roina is standing on the beach but is not interactable after you find all 5 hair pieces. STILL bugged Nov 2023.