Years of war conquest not completing certain sets

Zunimassa and helltooth Witch Doctor sets on ps4 are not registering as complete despite being on the Years of War list of sets. How do i fix this bug? Ifs the last objective on my season journey

Have you tried other sets ?

You need to perform a GR 55 with 6 different sets… what sets have registered for you so far ?

1 Like

Firebird, Marauder, Natalya, tal rasha and Shadows mantle all worked fine for me. I am on the leaderboard though so doesn’t that mean the quest completed?


Marauder, Natalya, and Shadows are DH.
Firebird and Tal Rasha are Wizard.

So you already have these 2 classes (+ your WD) levelled up to 70…

Have you tried the other sets for those 3 classes ?

  • Gears of Dreadland or UE with a DH
  • Typhon, Delsere, or Vyr with the Wizard
  • Mundunugu, Arachyr, or Jade with the WD

You only need one more set to register to get the conquest…

?? dunno… I don’t play Consoles and I don’t know what leaderboard you’re referring to.

But if you’re stuck with that conquest, you got to try something else… another set… another conquest. It is very unlikely that Blizzard will come around and fix the problem during this season.

I’m actually hoping that another PS4 player will see this and say whether the conquest can be done… and if so, what sets he got it done with… or if that conquest is totally broken. I am unfamiliar with the conquest situation on the consoles.

Good luck in your games !

1 Like