Wings of Terror

Hi, after finishing every seal and unlocking every power still no wings of terror. I`ve tried to restart the game and still no wings. Could you help me out?

Just to be sure - did you also unlock the wings? I mean, after you unlock 26 seals and 3 potions, you have to unlock the wings (it does not cost anything, just select the wings and click unlock on the left).

1 Like

where is that option, because nothing pop up after i click on the altar of rites

Click the wings that are below the potions.

thats the thing. there is no option for that. so annoying!

Oh, you mean, when you open the Altar, you have only a map on the left? Without buttons?

When I unlocked the last potion (finally, after getting my 6th primal), there was “The Last Seal” (or whatever is actually is in English - I have a different language now) on the left, with the “Unlock” button beneath. Seeing this, I selected the head below the potions (not wings, I apologize for my mistake), then the “Unlock” button activated. After clicking this, the Altar was really complete, and now there’s only a map on the left (no offerings, no buttons etc).

Wings did not appear in my cosmetics, so I quit the game and started a new one - no log off/log in, no restart of Diablo - just recreated game like you normally do when you want to reset bounties for example. After that - the wings were there.