Weapon bug in new patch - Fortress Ballista

Its my fortress ballista thats bugged, i can not get any gems into it


More on this issue.
this is following a hotfix that changed the ability to put a 2nd soul shard in a weapon (first in main hand - 2nd in off-hand)

this hotfix has removed the ability to put a soul shard in a 2nd weapon.
but now we are unable to socket Any colored gem into the off-hand slot (error message says “this gem cannot be socketed into this item type”

The patch was to prevent people putting soul shards into their offhand weapons.

What they seem to have done is prevent people putting gems into any off-hand item, including standard gems like Amethysts, Diamonds, Emerals, Rubies and Topazes.

Yes i know that, and i was waiting for them to fix it :slight_smile:

Go to Shen and remove gems from your wep (even though it doesn’t show one socketed it will work) and then restart the game.

Same issue here. It isn’t even the off hand weapon is the fortress itself. I moved it to main hand and still wasn’t able to put anything in it. Then I removed Dawn completely and still wasn’t able to socket anything in the Fortress.

Apparently, unsocketing both of your weapons and re-starting the game should allow you to re-socket gems into the weapons.

PTR just patched again. Maybe they fixed it.

Tried this 15 minutes ago. I was able to socket the shard of Anguish into the primary hand weapon and an emerald into the off-hand weapon (both equipped). Appears to be fixed.

Edit: Dawn and Fortress Ballista.