Unobtainable: PS4 Trophy "Terror in the Blood" since 1.46

The trophy “terror in the Blood” is not obtainable. I have tried all possible ways, but as you can see in the PSN profile forum, no one has been able to earn this trophy since 12 September, the day before patch 1.46.

Since it is the last trophy I am missing for the 100% and also the challenge ingame is not triggered, I would be very happy about a bug fix. Because no matter if you defeat Diablo in adventure or in story or hardcore mode, and use an attack that deals damage and is below 10%, the trophy doesn’t want to pop.

I hope you can help me and the other many diligent trophy-hunters out there.


I have the same problem, I’ve tried everything and nothing.

1 Like

Same issue. Kept killing him , till I checked PSNProfile’s forums and read that its happening for others as well.
Its one of the last 2 trophys left to unlock. Hope it gets patched soon.

Yes I have the same issue. Is there a workaround yet?

I am also having this issue.

Im currently on xbox and im having the same issue. I tried mutiple consoles, ive deleted my saves twice… ive killed dablo both moves that took health below 10 health mutiple times. A friend of mine beat obtained the achievements a few days i got the achievement. I swore i was losing it but he got it on the first try

Everytime i attempted this, i never obtained the challenge in game.

Hope this is fixed, this is the last achievement im missing as well. It only became the last because i wasnt able to unlock it when i had 5 achievements left. Progress is stuck at 50%