Super lag spikes on greater rift 120+ 4man

HI,

on ruining greater rift 120+ 4 man, it’s impossible to complete due to a super lag spike on high density .

is there any fix please, because i see people doing it on you tube with a much higher gr and much much bigger density groups .

Alwared,

That sounds like a performance issue. Have you tried anything to fix this on your own yet? If not, I would try the troubleshooting in this link. you’re still having trouble after this troubleshooting, please generate a text copy of your DxDiag using these instructions. Once you have that made, open the file. Copy the code below, then copy/paste everything from that DXDiag file between the rows of tilde (~) marks where it says “DXDiag goes here.”

~~~~
DXDiag goes here
~~~~

If the file’s too large to submit, you can upload it to a file hosting site like pastebin and post the link in the code above instead.

Hi and Thank you for replying.
it’s not a performance issue. what is going on is happening with the 4 of us at the same time. when we try to get a big group of mobs plus 2 or 3 elites together, a lag spike occurs and you notice that the latency goes from 60-50 ms to 2000 after the spike is over and we are all dead or 3 of us dead . it takes few seconds to go back to normal latency and it stays like this on every big push.

please note that we are plying from different countries

as for the PC performance , it’s a core i9- 9900 intel cpu with 2080 ti . i don’t think it’s a performance issue but i will post the required info none the less below

https://pastebin.com/ZBBeHMBm

Heya alwared,

Interesting. That’d be the first I’ve heard of this impacting several players simultaneously. If you’re seeing the latency increase, we’d want to try to track why that’s happening instead. Your DXDiag looks pretty good with the exception of an issue where you had a memory leak problem while playing diablo, which probably wasn’t the problem you’re reporting here anyway, so let’s see if we come up with anything connectivity wise.

Instead, let’s create a WinMTR test which catches a couple of these latency spikes. You want to restart the test every 10-15 minutes until you catch one of these problems. Once you’ve caught one red handed, run the test for about 5 more minutes. This will let us look for problems between your house and our servers which may cause this.

If you have problems with posting it due to a link error, go ahead and copy paste this into your next post, and replace “WinMTR goes here” with your test.

~~~~
WinMTR goes here
~~~~

4-man groups, especially if some of them are running high amounts of Area Damage in particular builds (e.g. WW/Rend Barb, Firebats WD) are notorious for experiencing huge amounts of lag in high level GRs. It’s fairly easy to reproduce. Just take four WW/Rend Barbs into a GR125+, gather a few screens worth of mobs, and start hard casting some Rends. The game will lag out and it’s because the damage calculations are done server-side and that amount of area damage / bleed calculations means it can’t keep up.

The issue also affects high end solo games. If you watch some of the videos of WW/Rend Barbs doing solo GR pushes in the GR140-145 range, when they’re in very high mob density you’ll see them regularly press escape to get to the menus. They do this so because they’re lagging out. Going to the menus pauses the client and allows the server-side calculations to catch up. Then they come out of the menus and response is normal again for a while.

I’m not sure what a WinMTR is expected to show, when four players, in four different countries, with four different ISPs, with four different traffic routes, all experience the lag simultaneously.

2 Likes

Ruling things out more than anything else, though the player did say that their latency increases significantly so I was curious if it would show something of value. If this is a reproduceable issue expected to be a bug with calculation with certain builds, however, then this is the wrong forum for it - you’d want to go to #bug-report instead. We’re not devs here, we just try to get the tech support issues worked out.

1 Like

Yup this is Area Damage. It breaks the game.

I can confirm that this is a server-side latency issue. During nearly every 4-man GR120+, all four of us players experience simultaneous lag when grouping two or more elites. I can also confirm that it doesn’t always happen in sync with season buff either. Sometimes the buff goes off and there are no issues. However during slow down /freeze, all of our pings spike and game becomes unplayable. Eventually the server catches up and there’s a massive speedup but usually everyone has died by then. Please fix Asap as the group GR has become unplayable. We are on NA servers with different ISPs.
Edit: Group composition is usually zdps barb, dps dh, zdps monk and either dps necro or wd (all with current Meta builds respectively)