Slow load times - Inventory

Having the same problem with my characters too. Never had them before yesterday. Everything fx setting is low.

System iMac (27-inch, Late 2013)
OS macOS High Sierra 10.13.6 (17G13035)
Filesystem APFS
Startup Disk Macintosh HD
Processor 3.5 GHz Intel Core i7
Memory 24 GB 1600 MHz DDR3
Graphics NVIDIA GeForce GTX 780M 4096 MB

Same problem here, the inventory takes SO LONG to load

macOS Catalina (version 10.15.5)

Macbook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
Processor 3.1 GHz Dual-Core Intel Core i5
Memory 8 GB 2133 MHz LPDDR3
Graphics Intel Iris Plus Graphics 650 1536 MB

I also experience the same load times with inventory after the new patch. It is really annoying so a fix would be appreciated

My system info:
Model Name: MacBook Air
Model Identifier: MacBookAir6,2
Processor Name: Intel Core i5
Processor Speed: 1.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 8 GB
Boot ROM Version: 121.0.0.0.0
SMC Version (system): 2.13f15
Serial Number (system): C02L33MLF6T5
Hardware UUID: 58395C5B-6CE1-5C0C-BBFB-14EE7A4C5C05

I managed to fix it temporily (dunno how long it can last but it seems fine to me for a few hours)

  • Delete the battle.net cache folder
    Source: https://us.battle.net/support/en/article/000034721
  • Login to the game and change every video effect setting to high and also uncheck Low Fx
  • Go the vendor and check if it loads instantly, if so change your setting back to the original settings.

Update: A new sessions of the game seems to bring the problem back so I did a quick fix with setting all quality to high > check if its working > set it all back to low(I am using all low fx to play)

Appreciate the details provided so far! We’ve seen a few reports of what betaSavvy suggested seeming to help. Thanks for sharing! Does adjusting the graphics quality seem to help with the slow inventory issue?

I just tried another new session - started at Act II, check inventory/vendor and it loads normally, went over to other Acts and the inventory/vendor loading lags.

Went to my settings - this time I only switch the first option Texture Quality to High, tried to check the inventory/vendors and it loads normally. Switched it back to Low after that to continue my game as per normal.

So far now it’s a work-around, the problem is affecting our game play experience and hopes a more permanent fix is on the way.

1 Like

I try this but it still doesn’t work. Still the same annoying problem. I really really do hope that Blizzard comes up with a hot fix soon.

I am also having this problem recently. I play on an old MacBook Pro 15", from mid 2012.
Anyone else?

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Quad-Core Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB

NVIDIA GeForce GT 650M:
Running APFS file system

Same issues here.

Model Name: iMac
Model Identifier: iMac19,1
Processor Name: 6-Core Intel Core i5
Processor Speed: 3.7 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 9 MB
Memory: 40 GB
Chipset Model: Radeon Pro 580X
1 Like

I’m having the same issue. Also, the quest giver exclamation point isn’t showing up.

Model Name: iMac
Model Identifier: iMac14,2
System Version: macOS 10.14.3 (18D109)
Processor Name: Intel Core i7
Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Chipset Model: NVIDIA GeForce GTX 780M
Memory: 32 GB
Boot ROM Version: 133.0.0.0.0
SMC Version (system): 2.15f7
1 Like

Those of you posting need to also post your OS version as well. Also, please check the drive(s) you are running from and post what the filesystem is. It will be one of the two below:

HFS Extended (Journaled)
APFS

The reason we need this info is to further narrow down the cause of the problem. For those that already posted, if you could simply edit your post instead of creating a new one that would be great (it would make it easier to parse the info as it is all in one place as opposed to scattered piecemeal through the thread).

1 Like

Icons taking too long to load…

3 Likes

Howdy Folks,

Been playing Season 21 pretty much all week, and just had this issue poopup yesterday, after playing for around 4 hours. I thought it was my MacBook Pro overheating and the system slowing down, but when I exited the game and checked temps, they were holding steady at around 68C, so that wasn’t it. I also thought that perhaps it was a memory leak in the game, as it didn’t start until I had been playing for awhile? I quickly loaded the game to test it before making this post, and did NOT have the issue. So it seems to develop over time for me. I also did not change any settings.

Here are my specs:

Model Name: MacBook Pro
Model Identifier: MacBookPro16,1
Processor Name: 8-Core Intel Core i9
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache: 16 MB
Memory: 16 GB
Chipset Model: Radeon Pro 5500M 8 GB
macOS Version: Catalina 10.15.5
System Disk: Apple SSD
File System: APFS
Diablo 3 Version: 2.6.9.68722

Of note, I also have the issue with some translucent graphical effects rending with a bunch of black boxes. This season the easiest way to see it, is with the giant snow balls that spawn due to the season buff. This is cosmetic, and does not seem to causing any real issues.

Thanks!
Rich S.

It would appear that this issue is APFS related. Or more accurately, a combination of APFS and the game’s own filesystem, CASC.

The issue with CASC is that over time as patches are downloaded, the data and index files become fragmented, which slows performance down, sometimes noticeably. And because CASC files are patched in many different spots, every single change is accompanied by a new b-tree extents node under APFS, which causes severe performance degredation due to having to enumerate every last node for each file that is read from on the drive. It gets even worse if you are using a platter based hard drive instead of an SSD (SSDs mitigate APFS’ enumeration issues to an extent, but not completely as you’ve seen here in this thread).

One way to fix this for an APFS system, at least in the short term, is to uninstall and reinstall Diablo 3. This is actually easier than it sounds. To do so, you simply need to go into your /Diablo III folder and delete the /Data folder (while the game is not running of course!), then emptying the trash. When you start up the Battle.net app, instead of “Play”, you’ll see the big blue button for Diablo 3 reads as “Update”. Click it and let the game reinstall. You’ll have a fresh set of files that are as contiguous as possible, have no edits or changes (patches) to them, and will run markedly faster under APFS than a game that has been patched multiple times.

Note: If you have the Diablo 3 PTR installed, you need to delete that first, otherwise the Battle.net app will attempt to copy existing data over from the PTR folder and then patch after that has completed. You don’t want that because that just trades one set of fragmented files for another. With the PTR folder deleted, you’ll have a roughly 17 GB download. Go make a snack or three unless you have 300 Mbit/sec or better internet, because 17 GB takes a while to download.

This should restore some, if not all of your performance. The icons are loading slowly because they’re being read very slowly from the drive, and it’s the combo of APFS and CASC causing it. It doesn’t matter how fast your internet is because the icons aren’t downloaded, they’re read from the game data on the drive that Diablo 3 is installed onto.

Also, it should go without saying, but do not click the Play button until the installation has completed. Doing so will almost always corrupt your game’s files. CASC is finnicky like that. Always let the installation or patching finish before trying to play.

6 Likes

Thanks for the detailed explanation! Just a question, any idea why setting the Texture Quality to High ‘fix’ the issues?

It’s possible that the high quality textures are funcitonally fine and the low quality textures became corrupted at some point. Usually this happens when a player clicks “Play” while patching or installation is still going on. That’s why I noted to always wait until everything finishes before clicking Play. CASC is really dicey when it comes to playing while simultaneously downloading game assets. It almost always leads to corruption and bevvy of problems down the road.

Thank you TheTias! I am doing the ‘UPDATE’ now!

1 Like
Model Name: MacBook Pro
Model Identifier: MacBookPro11,5
OS: macOS High Sierra (10.13.3)
Processor Name: Intel Core i7
Processor Speed: 2.5 GHz
Memory: 16 GB
Chipset Model: AMD Radeon R9 M370X
File System: APFS

Few days ago deleted the “/Data” folder and let the game update (downloaded ~17GB). Still experiencing the same issue. When it happens I have to toggle between low and high graphics.

I have this issue, but only in multiplayer, and only after a new player joins the party (not immediately upon joining a multiplayer game). If I leave my inventory or stash open, everything syncs up eventually; then the problem goes away until a player leaves and another joins.

Model Name: iMac (Retina 5K, 27-inch, 2019)
Model Identifier: iMac19,1
OS: macOS Catalina Version 10.15.6
Filesystem: APFS
Processor Name: 8-Core Intel Core i9
Processor Speed: 3.6 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache: 16 MB
Memory: 64 GB
Chipset Model: Radeon Pro Vega 48

I suppose it needs to be asked then for the other posters: Is this happening during solo or just multiplayer? I do know that multiplayer syncs everyone’s client, including all of their stashes even though nobody can see your stashes.

Well that sucks. But at least the CASC portion of the problem was eliminated for a while anyway. That would still leave APFS as a potential culprit since that seems to be the filesystem everyone here is using that is experiencing the problem. I know there is a slight delay even on HFS+, so APFS only gets worse.

Total bummer. :frowning: