Possible Bug in Armory

  1. I saved a set of Gear in the Armory.
  2. Overwrite with a new set.
    Now in the old set was a Ring with a Gem in it.
    The Ring is nowhere to be found anymore, not in inventory/storage, as is the Gem that was inserted.
    Strangely enough the Gem shows up when you finish a Greater Rift and you can update it.

The armory doesn’t recycle items, so either you searched incorrectly or destroyed it by mistake.

If you can increase the gem, it’s there somewhere. In your inventory, your chest, on you or on one of the companions.

ps: If you are currently playing in non-season, there is a Bane of the Trapped equipped on the enchantress of the barb Eagle and, two another gems on the templar of the dh EagleGo


I had somebody other day couldn’t find a gem. She said that she thought she put it back with the other gems. After awhile she did find it. It was in a ring.

Thanks for the heads up!
I shouldn’t post at 3am.

How do i mark this solved?

I don’t think you can in this Bug Report forum. Only the Technical Support forum.

You could edit the title in your original post to: [Solved] Possible Bug in Armory. (Or something like that).

1 Like