Haedrig's gift mail missing (SSF)

I worked on completing the first 4 season journey chapters on my new SSF season DH, yesterday and today, and encountered what appears to be 2 bugs or issues?

  1. None of the Haedrig’s gift mails arrive in my mailbox, on chapter completion. I see the green mail sack getting generated upon chapter completion (for a second or so, before it fades out), but I never receive the actual ingame mail message. This happened for all three Haedrig’s mails. They pop up on screen briefly when being generated, but I never get the actual mail or items. Looks like my mailbox is empty. So I can’t get my starter set.

Restarting game, relogging char or logging on other chars does not fix it… still no Haedrig’s mail despite completing chapters 1-4.

Note 1: After creating this char, I opened the mailbox initially and deleted the 2 old RoS items.
Note 2 / edit2: I just discovered that I had stored 3 unopened Haedrig#s bags in the non-ssf stash (had completed most of the season journey in non-ssf on another char before creating ssf char). It’s still a bug I think ( assuming ssf and non-ssf don’t share sseason journey and both can receive the Haedrig’s set at least once per mode), but in a pretty rare scenario for live. Opening the Haedrig’s bags on non-ssf char did however not fix the mail on the ssf char… that one still does not receive the Haedrig’s mails.

  1. After completing chapters 1-4, specifically after completing chapter 4 of the season journey, the season progress tracker disappeared. When I click the little green leaf button in the top right screen corner, I get an empty window pop up (see other post, where someone else also reported this issue). Restarting/relogging etc. does not help.

Effectively, my char is now dead in the water concerning its season journey. Hope this get’s addressed before launch. Thanks.

ht tp s://imgur. com/a/uGioRic (remove spaces)

/edit: The class is DH and Haedrig’s gift set should be Shadow Mantle.

You can only receive the Haedrig’s gift once per SEASON, no matter the mode, even Hardcore is not counted as a separate mode for the journey.


Ah ok, did not know that, thanks. Then it’s not a bug. Edited the title.