[FIXED] Settings not saving

I’m trying to improve my performance, so I tried to reduce FPS to 30 max on foreground (down from 150) make fullscreen the default and changed the resolution. But I have to do it every time I open the game because it doesn’t save.

I don’t know if it matters, but I uninstalled the game after years not touching it at some point, but reinstalled a few weeks ago.

-Running as Administrator
-Resetting my browser
-Stopping any OneDrive synching
-Repairing files.

None worked, and those are all the answers I can find in these forums.

Did you try manually editing the d3prefs.txt file?

What’s that and how do I do it?

Check that you don’t have any “additional command line arguments” set in battle.net to force it to run in a windowed form. eg. -launch -window
(see below)

FIXED: d3prefs.txt was set to read-only.

(Found the file through startup menu, right click > properties > un-tick the appropriate box)


I also just had this issue due to OneDrive not automatically downloading the d3prefs.txt

1 Like