Diablo IV Launch Crash - Version Not Supported

Every time I’ve launched the Diablo IV Beta since the first day I was invited, all that happens is I immediately get an error message saying “Version Not Supported” - “You need at least Windows 10 (version 1909)” right after the Diablo IV splash screen.

  • All of my other blizzard games launch and play fine (WoW, WoW Classic, Diablo 3, Diablo 2, Overwatch 2)
  • I have a legit registered copy of Windows 10 Home (Version 10.0.18362 Build 18362)
  • I’ve tried uninstalling/reinstalling, scan and repair, etc. of Diablo IV.
  • I’ve tried launching D4 in Administrator Mode, Compatibility Mode, etc, nothing helps.

Windows 10 version 1909 should be build 10.0.18363 (cf: Windows 10 version history | Microsoft Wiki | Fandom).
As far as I can determine, build 18362 is version 1903.
Have you tried to upgrade Windows to a newer version ?

P.S. : The support for Version 1909 ended in May 2021.
(cf: Windows 10 version history - Wikipedia)


Not sure what to do - I install all the windows updates and as of right now it tells me “You’re up to date”.

When I run the PC Health Check App, it tells me “This PC meets Windows 11 requirements” but just tells me Windows 11 is “free and coming soon”. The PC Health check also claims “You’re running Microsoft Windows 10 Home Version 1903”.

The build number I posted came from the generic “System Information” app from Windows.

Either way, why does Diablo IV, unlike all the other blizzard games (including other Diablo versions) have this impression that my PC can’t handle it?

You can down the newest version from Microsoft. You should be able to run as a update or burn a copy and run it from with windows. It will update to the newest version 22h2.

1 Like

Windows 10 (version 1909) was a 2019 version that stopped being supported last year.
22H2 v19045 is the latest version. Why would we want to rollback windows?
Can anyone get into the beta on a windows pc?

It isn’t telling you to roll back the version of windows. It telling you that you need version 1909 or higher to run the game.

Plus if he is running windows version 1903. He should be getting warnings that version is out of date from Microsoft itself.

1 Like

Update on this: I took the issue to Microsoft Support and apparently you can have a corrupt OS such that you get security updates…but somehow not build/version updates. We tried to manually update the OS but it failed, so I’m about to have to reload the OS. Good news is they’re letting me jump to Windows 11 :slight_smile:

Thanks for the feedback everyone.


Please let us know if windows 11 solved the problem.