Diablo 3 won't save my preferences

Before installing the Rise of the Necromancer expansion, everything worked fine. After downloading, my d3prefs.txt file just disappeared. The game won’t create a new one, even after trying quite a bit to fix it (scan and repair, full uninstall/reinstall (including battle.net), and even creating a d3prefs.txt file for it to save to).

EDIT: I took a look at my D3Debug file and it says;

“ERROR: Couldn’t create preferences directory. Path is locked or missing?”

EDIT 2:

I found the problem. I will leave this here for people who may have the same problem.

On Windows 10, with the most recent update, they added a security option called Controlled Folder Access. By default, this is turned on. You need to turn it off for Diablo 3 to make/edit a d3prefs.txt file.

1 Like

I’m having the same issue, but I have Controlled Folder Access turned off.

SOLVED: Renamed D3Prefs file and the game created a fresh one for me.

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.

1 Like