Diablo 3 / PS4 ,,There was a problem with joining game"


We have a one problem on ps4. When we try play together with ONLY (i mean if im gogikg to start party only with him) one of my friends and possible players. After inviting/adding players into party in diablo 3 game return game otification window with : There was a problem joining game"

We tried many options but without solution.
We both can connect to other players. But not each other. When someone third create party we can connect and play together.

We have :
Same NAT type B(2)
Actual ps system and game
same region in game
Same date and time settings
Tplink archer c50 and tplink c60 routers. Actualy port should be open when we can play with other players.

Where can be a problem?
How did you solve it ?
I google it with tens problem discussion, but every one of them without the real answer/solution

Thanks for your help

Restarting the PS4 mostly helps when I get that message.

Sometimes it is ISP related too. Changing DNS severs to something other than the ones your router assigns you helps (OpenDNS).

There isn’t one fix for all, sometimes it is NAT issue, port forwarding, ISP, simply restarting, changing DNS etc.

1 Like

It can also be console specific. I have a PS4 slim, my girlfriend has an original PS4. She can join all the games she wants. If I try to join I get that a lot. If we play with friends they get that error trying to join me. But we can all join her game. It is very odd.

Found the solution. You need to set up port forward on your router… it works like a charm for me now… blizzard could have just pinned the answer for all consoles facing this issue…

From sony’s website
you may need to open (forward) the PSN ports on your router.

Ports act as endpoints between two connections, and opening the specific PSN ports can help direct the flow of internet traffic between PlayStation Network and your PS4 or your PS5. IMPORTANT: If you’re not sure what this means, or you don’t know how to open ports on your router, we strongly recommend speaking to your ISP or router manufacturer before changing any settings on your router. Try opening the following ports on your router, then let us know if it solved the problem.
TCP: 80, 443, 3478, 3479, 3480
UDP: 3478, 3479