Diablo 3 Audio issues anyone else javing these isaues


#1

Help, i logged on the other day and saw the Bnet notification of issues that where happening in D3 logged in anyways and my god the audio was horrible so i logged out and tried again today and same result nuthing but static and distant reverb in game and while in the lobby anyone had this issue? Know a fix ive checked all drivers ran the rescan and repair other blizz games work great etc.


#2

I’m having the exact same issues. I even uninstalled & reinstalled the game, but it didn’t fix the issue at all. Did you find a solution?


#3

Windows 10 ? Did you recently installed a Windows Update (KB4515384) ?

If so, that update is causing some issues in D3 for some… see :
https://support.microsoft.com/en-us/help/4515384/windows-10-update-kb4515384
(scroll down to known issues)

A new update was released by Windows today to fix it… see :
https://support.microsoft.com/en-us/help/4517211/windows-10-update-kb4517211

Good luck…


#4

I don’t understand…why would it literally just affect D3, and no other program?


#5

I don’t know… a user had the same issue in French language Europe forum…

Blizzard recommended uninstalling the KB4515384 update… that did the trick.

When I checked Windows site tonight (to get the English version of the article), I noticed that Microsoft had issued a fix.

So I thought I would mention it.


#6

I appreciate it. Thanks! I’m looking for it to see if that can be the cause.


#7

Well, that did not fix the issue…ugh.


#8

I’m sorry to hear that… best of luck with this.


#9

I logged in today having not played for a while and same issue. Extremely low bit rate audio, distorted and making the game unplayable. I tried all audio settings, changing audio outputs, I scanned and repaired the game and then tried a fresh install. Nothing works.


#10

I had something similar happen after a recent Windows update (not the one the KB article was talking about.) Turned out the update did something to reset the audio properties in windows itself, so I had to re-do the settings.

It might be worth double-checking the audio properties in Windows control panel.


#11

You may also want to try toggling spatial sound off in the Windows volume settings (right-click speaker icon).