Dashing strike uses 2 every time

Please help. For the love of me i simply cannot stop my game using both stacks of dashing strike virtually every time. I have tried so many things. It is stopping me doing high grifts. I ask in game but it seems a common problem?

1 Like

Frustrating eh ?
I found it more common when using right click. Seemed a bit better using keyboard instead.


I wonder if just slowing down the character repeat delay in keyboard properties or system prefs would work ?

Character repeat delay settings shouldn’t help, since D3 keyboard system doesn’t seem to rely on any character repeats. It seems to use key down + up events.

And about autohotkey solution: while this would fix the problem, note that third party software is forbidden in EULA.

Would be nice to get a proper solution. I’d be happy with all teleport style skills executing only once when key goes down.

This has been an issue for years so I would not count on it being fixed, ever.

I’ve had this issue too. For years.

I agree. This is the way.

This is the way.

but why…

If you play monk and not having in geom for infinity dash, what are you doing with your life ?