Challenge rift not updated?

Logged on after work today to run the challenge rift and noticed that my xbox had me in an instance still in the old CR (274), it’s happened before, just had to close out and relog and it would update. Not the case today… I’ve tried everything I know to do short of uninstalling and reinstalling and I’m hoping someone has a fix before I do that. I’ve tried closing the app, tried forcing an update (none listed available), i tried a hard power cycle of my xbox, and none of those seem to change anything. I still have access to seasonal and multi-player so it would seem I’m up to date. If I chose “game settings” to try and set uo s multiplayer instance it just tells me “challenge rift 274 has ended” and if I choose quick match it will drop me into an instance of the ready room but not let me into the rift itself, shows a message “this challenge rift is no longer available”.

If anyone has a fix for this that would be lovely as I’ve been trying to maintain my placement on the leaderboards. Been top 5 every week this season and 1 more often then not for xbox NA CR’s.


It’s not working on switch either.

1 Like

Still not updated here as well. I’m also playing on Switch.

1 Like

Same here on console (Xbox) Tue 10:30am CST. The old rift is still up and gives you a message saying the rift has ended. I’ve logged off and on, restarted the console, etc etc.

Same story for me and my gamer buddy :confused: xbox version

On xbox, still not updated 1am Wednesday

Like what is going on am I never going to be able to run a challenge rift again or what why the hell is this challenge rift not updating. Playing on switch. Have never had this issue before and I have power cycled the switch about 5 times now. I am not wanting to waste time uninstalling and reinstalling. Fix your game Blizzard.

I honestly thought it was like a switch thing. Glad to here is like all consoles. Glad i’m not crazy I couldn’t find anything about a fix. Hopefully they are working on it.

Bumping. Issue still occuring on switch as of 28th. I can’t seem to see acknowledgement of it anywhere but this thread (admittedly I’ve not spent a huge amount of energy looking).


Still that way for me too

Fixed on Xbox at last :sob:

Ok on PS…there you go.

Not a challenge Rift but a GR. None of my times are updating to the seasonal hardcore rankings. Im on PC.