Catalina OSX graphics issues

It could be that OpenGL events no longer trigger the switch properly in Catalina. Apple may have purposely changed that subsystem to only detect Metal events, in which case D3 wouldn’t trigger switching to the discrete GPU as opposed to the IGPU built into the processor. Both should trigger the changeover, but again, we’re talking Apple here. They’ve been known to artificially deprecate things to force users onto their “preferred” systems before. I wouldn’t put it past them that this is why you now have to force it yourself instead of it being automatic.

I didn’t find that worked for me.
same problem with auto graphics switch on or off.
What does work for me is starting D3 and if the problem manifests, quit, then restart D3, not the Mac.
greatest number of sequential restarts of D3 has been 6 (it’s usually 3-4, sometime it works first time) before it starts properly.
No big deal now but a bit boring.

I believe, TheTias, is on to something here. We’ve seen some pixelation issues with OpenGL and crashes for Metal in particular with Radeon Graphics in some of our other games. It’s more than likely that this is related after the Catalina upgrade that there is a driver or graphics API issue on Catalina.

We haven’t been able to replicate the issue with Nvidia graphics cards as of yet. Does anyone have this issue without a discrete Radeon graphics? If you could include the requested details that TheTias requested alongside the Discrete Graphics card in the system:

1 Like

im on OS Mojave, i doubt the OS will have anything to do with it?

Ive got: AMD Radeon R9 M395 2048 MB
And getting a lot of pixelated “boxy” areas.

Is it a serious issue?

1 Like

This worked for me! I’m on OS X Catalina Radeon

I am able to recreate this on a MacBook Pro with Radeon discreet card.

MacBook Pro (15-inch, 2018)
Radeon Pro 555X 4 GB

I can recreate the issue anytime I drag an item from inventory to another window like stash, or a vendor. Or if there is a in game sequence like when you kill Diablo and there is a letterbox in game custscene.

1 Like

Thanks for your reports! I’ve actually seen one other report of this happening for Diablo III and Mojave specifically.

Our other games (Starcraft II & Heroes of the Storm, specifically) have had issues with Radeon graphics due to a driver issue on Catalina that will be fixed with a driver update in the future. This is mostly why I tied this with possibly some driver issues, but it seems more like Diablo III and MacOS may not be detecting and keeping the automatic switching set properly as Chocopipe pointed out.

With also having reports on Mojave though, I’m a bit curious if there’s something else to this. Anyone having success with disabling Automatic Switching for the GPU as well?

Thanks folks! I’m going to get this tracked and gathered, any additional reports and success on if this works for you is appreciated :slight_smile:

1 Like

Hello @Caterpepi,

My config is the following

  • MacBook Pro (15-inch, 2017)
  • macOS Catalina 10.15.1 (19B88)
  • Radeon Pro 555 2 GB
  • Intel HD Graphics 630 1536 MB

I manage to play by disabling Automatic Switching indeed.

Thank you for your time trying to fix the issue. It is always good to hear there is support.

Same issue here.

MacBook Pro 16,1
macOS Catalina 10.15.1
Radeon Pro 5500M 4 GB
Intel UHD Graphics 630 1536 MB

I had it work once, but I’ll try some of the suggestions mentioned.

Glad I found this thread!

So, I toggled between apps and when I went back I got a quarter of the screen. It was zoomed and took up my entire screen. I don’t know how to add the screenshot, and I can’t link it.

To add a screenshot:

  • First upload the screenshot to a picture-sharing web site, such as,
  • Then, copy-paste the website link in your message,
  • Then highlight the entire link in your message, and
  • Click the </> button on the formatting bar at the top of the window.

This will transform the link to preformatted text and will make it acceptable to the forum software. It will not be clickable, but others can copy-paste your link to their browsers. Your link will appear as this :

Here is the screen shot. The image is not frozen. I can even click on ‘Game Settings’ and move around, but I cannot shrink the screen or move to a different quadrant. Hope this link works.

Thank you for the reports and screenshots!

@Octar, I’m not entirely sure if this is the same pixelation issue that everyones been reporting, though that is an interesting issue. This could be a keybinding or hotkey set up being zoomed in as well. Does this happen in windowed mode?

Could you try checking the resolution and see if lowing it may help? If you have a Retina display, using Open in Low Resolution is also a good option to try as well.

I’ve seen one report with the resolution steps helping the pixelation issue as well, if anyone else would like to try and the switchable graphics step isn’t addressing the problem.

Since turning off the automatic graphic switching I have not had any issues. I have played successfully four times in a row now.

Thanks everyone for all your help, and this thread! For now it seems I have a fix!

Hello guys,

I came to this post because I had the same problem, but in my case, along with this error, my macbook has stopped going to sleep properly.

My computer is a macbook pro 15 inc 2017 with VGA Radeon Pro 560 4 GB. When these problems happened, I was using macOS Cataline. So I downgraded to Mojave, and the video problem in Diablo apparently was solved. But the suspension problem continues.

What I am suspicious of is the SMC firmware version which in my case is 2.45f1 (I think updated by Catalina). My wife has another MacBook Pro same version as mine, that didn’t upgrade to Catalina, she uses firmware 2.45f0, and she’s not having the problem.

I would like to know if you are also having a suspension issue, and which version of the SMC firmware, so we know if there is a relationship between these issues.

Suspensions are not tied to the SMC firmware. All the SMC firmware does in the Mac is control the primary systems (fans, audio, networking). It’s a hardware system created by Apple, not Blizzard. Apple has no say in Blizzard’s handling of their players and Blizzard has no say in Apple’s handling of its customers.

If by “suspensions” you mean you were silenced and are now unable to create a game, this sadly is a known situation. The bug(s) regarding it have proven to be somewhat elusive, but Blizzard is aware of the problem and is working on a solution. Until then, any silences will unfortunately result in a de facto “ban” for the duration of the silence. That’s the bug. Silences are meant to keep you from grouping or chatting outside of your friends list, not prevent you from playing altogether.

Since you and your wife must have separate accounts in order to legitimately play (account sharing is allowed only between parent and child, not two adults even if they’re married) and your wife does not have this issue, I need to ask - do you have a silence affecting you in Diablo 3 or any other Blizzard game currently? If so, you will have to wait out the duration of the silence I’m afraid.

If you believe your silence was in error, you can appeal the decision, but be aware that if Blizzard agrees with the initial decision to silence your account, they will uphold it. If you were erroneously silenced, make your case calmly and rationally and provide whatever details you can (without breaking any rules of conduct while doing so). Be as brief with your statement(s) as you can while providing as much info as you can. The more noise the person on Blizzard’s end has to sift through the more likely they’ll miss important details. Focus on the important stuff and leave out the chaff.

Same symptoms here exactly, and suggestions about auto graphics switching doesn’t fix it.

MBP 15in 2016
Radeon Pro 460 4 GB

Model Name: MacBook Pro
Model Identifier: MacBookPro13,3
Processor Name: Quad-Core Intel Core i7
Processor Speed: 2.9 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB
Boot ROM Version:
SMC Version (system): 2.38f8

It makes sense that you’d be seeing this. The Radeon 400 series is Polaris just like the 500 series is, and thus uses the same drivers and only slightly different framebuffers. I suspect this will happen to any AMD hardware though as those drivers were written purely with Metal in mind, not OpenGL, which the game uses as its graphics API. OpenGL optimizations were never a priority with Apple since they had unofficially deprecated OpenGL years ago.

Hello !

I may have found the solution while looking for the same problem for another game (Oxygen not included).

Right click the Diablo III’s .app file => get info => start in low res mode.
Once in the game, change the resolution for what you want and restart the game to check if it’s fine.

I replied on this post:
https:// us.forums.blizzard. com/en/d3/t/new-macbook-pro-i9-radeon-5500m-issue/7728/40

Solution found here:
https:// forums.kleientertainment. com/klei-bug-tracker/oni/issue-with-full-screen-mode-on-macos-catalina-r22388/

(Remove the spaces in the URL).

1 Like

Brilliant - This fixed the same issue I was having with Starcraft :smiley:
[edit:] Setting to ‘low res mode’ fixed it. Changing graphics switching did not.

Apparently, the new Mac OS 10.15.13 fixes the full screen problem. see here: New MacBook Pro i9 Radeon 5500m issue - #41 by NJKnight-1638?