Bug in Rathma gift - Can't finish Bounty


In MP today, we couldn’t finish the bounty. The last prison (or Jail) was not spawned on the map. But the indicator was present.

We tried TP to another zone and another act but it didn’t change (indicator present on the map but no object spawned)

I’ve made some screenshots if you need.

Consequence: Can’t finish the bounty and get the Horadrim cache.

I’m sure you did, but I’ve just got to ask: Did you check both sections of the Briarthorn Cemetery?

Sometimes the last one or two Prisons are in the second section.

1 Like


Well we didn’t have to. As I said, the marker was present on the map and we were standing right on it. Just no prison was there to click on.

We indeed push to the other part of the Cemetary to maybe kill all mobs and Elites. No luck.

Okay. I just wanted to check. There is a rare bug where you can destroy a Prison and the pin on the mini-Map remains. I wasn’t sure if that was maybe what happened to your group.


Could be the case yes, as DH I was launching Arrows and Missiles everywhere, could have destroyed it without seeing. If it is a known bug then I think that’s it :smiley:

The Death Prisons in this Bounty cannot be destroyed by ranged attacks. When you click on one, your Character runs over to it, unless you’re already standing next to it, and makes “melee” contact with it (interacts with it).

I believe this is a similar bug as the one encountered by some players in Act 1 called the Jar of Souls. When you survive the waves of Skeletons that attack you, the “Jar” that should be destroyed after the timer expires does not spawn, leaving the Event incomplete.

I was with a friend who play Crusader, maybe he crushed it during the battle. Could explain it too.

This just happened to me in the new season. The second prision was not spawned, but the marker was on the map.

Was able to go to the next section and find the rest and was able to finish, seems to be just a graphical bug

The mark only shows when you are close enough. If you find one in next section, then the mark wasn’t for this bounty.

The mark could be other quest. (There are multiple quests in a map.)

If it didn’t spawn, you couldn’t have it done.
If you could finish the bounty, then no bugs.

just happened to me. only shows on the map

1 Like

I can confirm that the bug is still there. It just happend to me.
I saw the prison, killed anyone just around and interacted with it. Another monster attacked me and I killed it with a whirlwind attack which also destroyed the prison. The marker was still there, and the bounty could not be completed.

The marker can remain after the prison is destroyed. You have to look at the dialog that shows how many have been destroyed.
It can also happen in the Catapults and Blood and Iron bounties. It does not affect the completion status.
Yes, the marker not going away is a known bug. You can still complete the bounty.



I almost gave up because thought it was a bug, but the bug is the indicator not going away after you cap one, not that there is an “invisible one”. I searched the area to the south and sure enough there was my 5th pot.


I had same thing but fixed it. The indicator was in first area, and like you I was standing on it and no prison. I went to the second area anyways, and found it there.