Artifact blank window when loading

As the title says, I get a brief blank window/box that overlaps the load screen when authenticating the account. It disappears within a second or two and then the character screen loads.

Occasionally, I will get the ‘Failed to load D3D’ screen as well but I can click past it.

Despite this glitch, the game goes on to load just fine but I am wondering what the momentary white screen is.

Hey there Zarkano,

It does sound odd that you can play sometimes but other times experience graphical issues like white screens or errors about D3D. That type of error is typically a drivers or hardware problem. With it not being consistent, I’d start simple by making sure your drivers are up-to-date. You may want to check for the latest one manually as Windows and the driver software may not always update as expected. Here’s a link to AMD and Nvidia’s driver pages if needed.

I’d also see if resetting the video driver settings helps since they’re not reset with updates. Following that up with a reset of the in-game settings so defaults are detected also won’t hurt.

If there’s still a problem, could you provide a DxDiag file please? Once you have it, just copy the contents of the text file created and paste it here between two ~~~ like so:

DxDiag Here

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

2 Likes

I followed the first two suggestions and don’t think I need the third. It seems to have resolved the issue.

The Nvidia drivers were all current as I am notified of updates and install them whenever available. I did a version check too.

However, when I moved on to reset the video drivers, I saw several parameter changes. I’m not sure which ones were reset, but upon restarting D3, there was no longer the white overlain window. I tried several times to be sure including a full reboot of the PC. The issue seems to be fixed.

Additionally, the fans on the video card are completely silent now, as they used to be originally. So that’s two problems solved in actuality.

I appreciate your help Ironthorne.
Thank you.

1 Like

I faced the exact unexpected odd issue described by thread starter Zarkano as well. Issue started roughly 10 days back, around 10Jan2022.

Tried all 3 methods:
Latest Nvidia driver, resetting video driver to defaults and the in-game settings to defaults.

Still getting the grey/white screen before loading into game page which takes longer than usual (before trying the troubleshooting methods) – especially after reset of in-game settings.

Hope you are able to assist. Thanks!