Achievements not unlocking

My wife and I have been playing on Xbox series X and several achievements have not unlocked when In game challenges are showing them as completed. The achievement tracker is not working and we have already deleted our save on console and in the cloud and started completely over already. Wtf??? How is this crap not working right?

1 Like

The Xbox has this issue from time to time. Often times, once you pass the achievement, the game keeps track of it, so that it never bothers to check again for the console achievement.

Some people say that doing a hard reset sometimes works, but I’m guessing that’s a game by game case. Unfortunately, it happens, and there’s really not much you can do outside of starting over from scratch. It’s one of the downsides of not letting you physically back up your save game to prevent cheating.

So is this an Xbox issue or a Blizzard issue? I have never had this issue with any other Xbox game.

It’s an Xbox issue. I’ve had it happen with a couple other games. And it’s not specific to any particular game. If conditions are right, it can happen with any Xbox game.

Like I said, some games allow you to just recreate the achievements to unlock again, whereas others, you just have to restart the game from scratch.

Hmmm…that’s disappointing to hear. We are going for 100% and the game seems to be doing everything to make that a nightmare. We are going to be on our 2nd full restart soon.

Hate to break it to you, but while Xbox does have issues from time to time, the issues with Diablo on the Xbox platform are 100 percent a Blizzard issue. The achievements have been buggy since the launch of the game. They are all tied to the corresponding challeneges, and if it didn’t unlock, your only option is to save scum so you can reset to a point where you don’t have it, or to delete your file and start over if you can’t go back.

I have had quite a few of the achievements not unlock for me. For example, when I hit level 70 in hard core it didn’t unlock, but I got the challenge. Waited a minute, still didnt pop.

So I did a save scum (deleted my console save and reverted to the earlier cloud save) and hit level 70 again, it popped immediately.

This has happened with almost 1/4 of the achievements I have unlocked in the game, so I have had to keep a careful eye on my save uploads.

My son has 2 achievements that he got the challenges for almost a month ago and they still haven’t popped. So unless you got really lucky, and it happened to be a server issue with Xbox, they aren’t going to unlock by waiting it out.

Head over to trueachievements and navigate to the game page for the X1 version of the game. Lots of people complaining in the solutions and threads for years about it. The 360 versions never had issues.


Unfortunately diablo doesnt allow to clean wipe your game / in game achievements. so once one of them or multiple are glitched you are just out of luck.

Having the same issue here.

Happened to 2 of my achievements initially, then I looked it up. As you say, trueachievements explained it, so started deleting my local save as soon as future ones didn’t pop (by the end of it, I was saving the game and quitting out of it to ensure there was a cloud save not too far back)…

Anyway, I’ve now done all but these 2 and wondering what the least painful way of getting them would be. I’ve got a few kunais cube powers, which I’m vexed by losing, but also have 6 or 7 L70s and 153 Paragon Tiers…

Anyway… Here’s my plan. If anyone has any other suggestions, they’d be more than welcome:

  • I’m going to give all my stuff to my kids accounts and keep it in their stash.

Then I’m wondering if either the below might work:

  • Try to back up the save on a pen drive
  • Remove the pen drive
  • Delete the Cloud save
  • Get achievements
  • Delete Cloud save off Xbox
  • Restore save from Pen drive
  • Download Diablo on another Xbox (Xbox 2)
  • Ensure the Cloud save saves to Xbox 2
  • Leave Xbox 2 switched off (or at least don’t open Diablo on it)
  • Delete Cloud Save off Xbox 1
  • Get achievements on Xbox 1
  • Delete Cloud save off Xbox 1
  • Turn on Xbox 2

Had anyone tried either of these? Any thoughts on whether they’d work?

Thanks in advance.

EDIT: Option 1 looks to no longer be a possibility (from what I read, option removed.

Tried Option 2 but when I came back to my Xbox, and loaded up D3 the save was gone. Progress lost. You suck, Blizzzard. :frowning:

At least 8 have all my stuff to my son’s account so will get that back and start again.

Hope this helps someone else.