Video and audio stuttering suddenly after recent update/patch

I started playing D2R a couple weeks ago, and it has been running great. Consistent 120 fps, no performance issues of any kind. I was impressed.

Since yesterday, the game is running poorly. The FPS is very inconsistent, frames are dropping, stuttering is very apparent, and the audio cuts out each time it stutters. This baffles me because I didn’t change a thing with my PC. No new software, drivers, or hardware changes. It’s unplayable.

I’ve tried changing every graphics setting in game, including capping my FPS to 60. Capping the fps to 60 still results in very choppy performance. I have tried every single solution imaginable that I could find online. In particular, setting the CPU priority to high, closing every single background program I can, disabling any overlay. After all of this troubleshooting, I made sure my GPU drivers were up to date. Finally, I tried reinstalling and resetting the settings.

When the game is paused at the menu, it runs fine and doesn’t stutter. The game also seems to stutter more often when I’m pressing keys on the keyboard - holding down any key just makes it stutter like crazy.

All of my other games work just fine. D2R too, up until today. Others are having the same issue I am, same as when this patch was released, as reported here: Reddit - Dive into anything

PC: i7-12700k, rtx 4080, 32gb ram, nvme ssd, Windows 10.

EDIT: It turns out there was a minor patch/update a couple days ago for all platforms, which might be the reason why this is happening.

I’m having the same exact problems since the patch update. Never had any issues before. RTX 3070, i7. So frustrating, as the game is almost unplayable with this amount of stuttering. Please let me know if you find a fix…I’ve tried everything.

I am having the exact same issue! I am so sad, because I love this game more than any other game, and the other day it was working PERFECTLY at ultra settings, 60 fps on my 3090 and an i7. Then a day later, I fire it up and now the FPS drops constantly to the 40s, and 50s, and then shoots back to 60. Its very jarring. Its like frames are missing or something. I have tried everything:

  • Reinstalling the game, to different drives
  • Restarting PC
  • Running different compatibility modes
  • Lowest settings + DLSS on performance
  • Different nvidia control panel settings, high performance mode, 60 fps cap, clamp mode, etc.
  • Tried different resolutions and windowed mode
  • Tried playing with a controller instead of keyboard mouse

Nothing has worked, the same exact issue persists and it makes the game unplayable since the FPS keeps dipping and the game is very choppy. I am guessing like the previous poster said, that the latest small update broke something…

I really hope its fixed, because this is my favorite game of all time!

PC: i7-13700K, rtx 3090, 32gb ram, nvme ssd, Windows 11

i5 12600k 3080 game running like garbage i even lowered settings i m playing on 4k monitor but i even did resolution things with dlss and it still runs like garbage.WTH were they doing none asked them to mess with how smooth game runs.Or Blizzard chose to destroy D2 playability for Garbage 4 with Lilith :smiley:

Adding a “me too” to this, stuttering after a small update a day or so ago. Tried updating graphics drivers (even did a clean install for good measure) and deleting settings.json.

Update - As a temporary workaround, it seems like setting D2R’s priority to “high” in task manager helps reduce the stutters. Hopefully this helps someone out!

Setting D2R’s CPU priority to high doesn’t fix or even help the issue at all unfortunate for me.

Quick clarification, are you setting the CPU affinity or setting the process priority?

Priority, sorry. Used to talking about CPU affinity a lot.

question, do any of you use any command line arguments to run the game?

I don’t use command line arguments, no.

I use the following:
-mod noexppenalty -enablerespec -txt

Why do you ask?

node isnt having problems so doesnt matter

sometimes people forget theyve extracted game files and are loading loose files that werent updated

??? I, and others, are having major performance problems with the game. That has not changed.

Ah right, I used to do that but it was far less beneficial once I upgraded to my 13th gen processor and I got sick of having to re-extract the files every time there was an update.

In addition to the process priority workaround I mentioned above, I also force Vsync “on” in NVIDIA control panel in addition to enabling it in D2R. For whatever reason I need to have it enabled in both places and always have had to since even before these latest performance issues.

I also block D2R in my firewall as there’s a performance boost in single player when you’re farming, but that’s irrelevant to your issue.

er sorry, brain died when i wrote that. i meant 'node is having problems even though they arent using command line arguments so it doesn’t matter"

Sorry but any updates on this? Still having the same issue, really wanted to play some D2 again… :frowning:

all of you with nvidia gpus that have this issue? try updating (or downgrading?) the dlss d2r comes with. they may have updated it (or downgraded it?) in the most recent update and its now having performance issues for some users? d2 will keep replacing it, you cant launch the game with bnet i think, or else bnet will replace it back to the same dlss version.

have any of you tried updating gpu drivers? i see op tried it and velker also tried it but its not impossible for them to be having slightly different issues.

I took a break from playing for a couple of weeks and started back up a few nights ago and have been experiencing this same problem. I had a pop up that I had a new graphics driver available before I started playing and after I experienced the stuttering and lag, I quit the game, updated my drivers, and tried to play again after restarting, and I’m still getting the same issue.

Definitely a problem with the most recent patch.

I want to play this game so bad, heh. But I can’t and it’s making me sad.