Stuck on Loading Screen [PC]

On one singular character (immediately following killing Andariel and talking to Warriv to go to Act 2), whenever I attempt to join or create a game, I get stuck at the loading screen. The door opens all the way and then nothing.

This doesn’t occur on any other character, though none of my others have gotten into a new act. When I fire up the Nintendo Switch version, I’m able to play on the character in question without any issues. The game also doesn’t crash or fail to respond, but I’ve left it sitting at the loading screen for 10+ minutes and no change.

1 Like

This has been happening to me ever since launch this morning… except I havent been able to join or create any game whatsoever since then.

My buddy is having the same issue. If anyone figures out a work around, please post

Having same issue, my pc and laptop both meets more than the basic requirements and i have been trying all day and cannot get past the black screen. D2 resurrected dead on day 1 [for me]

I have the same issue… can somebody help pls

Same issue here. It got stuck after the animation between Act2 and Act3. I had to close the game via the task manager. Since then it always gets stuck on the loading screen. Other characters work fine. Any solution @Blizzard?

I’ve finished the first act and I’m stuck with the loading screen to the second act. I’ve restarted the game, tried it a few times - nothing changed. What now? The beta worked better as I was able to get to the arcane sanctuary. Now I’m not able to get the game running in act two. I hope this will be fixed really soon.

Exact same thing has happened to me on two characters. Literally unplayable.

UPDATE. I tried a repair and it didn’t work.

However… I reinstalled the game and made sure that I applied the default settings and my characters are playable once again.

I’m not sure if it was the reinstall or applying the default settings but one of those did it for me. Good luck.