Can't click "Play" button - This Game Cannot Be Played Yet

my play button is not even lit up. i got 3 other friends playing now as we speak

1 Like

exited out of the launcher alone wont fix it. went into task mgr and ended the updater along with it fixed the issue. hf :slight_smile:

Hey all!

I’m working on a couple threads for issues some players are having and trying to create separate threads for them. If your game is not launching after successfully clicking the Play button, this is the incorrect thread. Go to the following thread instead.

If you are unable to click the Play button, that usually means your battle.net app just needs to be refreshed. Try completely closing the battle.net application, waiting 5 minutes, then re launching it. If that fails, try restarting your PC and see if the battle.net application picks up the changes.

Finally if even that fails, try repairing the game.

Let us know if you’re still having problems after these three steps.

1 Like

2 of my buddies are able to hit play but the game wont launch.
Their pcs worked for Beta / Alpha. Game won’t launch.

Restart Bnet it did bring it up for me.

You need to kill the launcher completely and relog and you should get it.

Relaunching Bnet will fix the play button being grayed out but if it dosent launch it wont help you.

Did all three nodda, “this game is not available to play yet”. Thanks for your hard work figuring this out, I will give up for now.

Hey there Zyron/anybody else still having this issue.

The options above seem to fix this for the vast majority of players who are having issues. If you’re still having problems with this after following the steps, you can reach out to our support team so we can find more options with you individually.

1 Like

Все что вы написали по большому счету бред и поможет максимум 1% игроков кто столкнулся с данной проблемой. Я уже написал также в техподержку и дал туда 2 файла dxdiag и еще какойто. Но дело не в этом, Дело в том что ваш пост тут неуместен. Вам говорят о проблеме а вы считаете что обращающиеся дибилы которые не знают простых вещей. Все что вы посоветовали МЫ уже пробовали… так что лучше посоветуйте что-то нормальное, или просто исправьте!

1 Like

This is what he said:
All that you have written is by and large nonsense and will help a maximum of 1% of players who have encountered this problem. I have already written also to the technical support and gave 2 dxdiag files and some more. But this is not the point, the point is that your post is inappropriate here. You are being told about the problem and you think that the converting f(*&^rs who do not know simple things. Everything that you advised WE have already tried … so you better advise something normal, or just fix it!

I get a kick out of you telling people to wait 5 minutes and try it again. That is hilarious. How about we turn it off and on again? Or maybe you should have left it as a standalone game that didn’t need the 1 million + players to log in to Battle.net to play it. It the same thing every time. Our software and hardware haven’t changed. The issue is on YOUR side. Blizzard has had years to figure out these issues, its like you used php to write your authentification server.

For real… stop telling me to “just restart, or reinstall, or refresh…” I have been at this for 9 hours now. The launcher states it is not available to play, thus the button is greyed out. PLEASE LOOK INTO THE ISSUE.

i have also the same issue…

Reposting the info here/locking thread. We can’t help everybody with this problem from a single thread so if you’re having this problem check out this information and if it fails contact us so we can help you individually.