WOW51900319 when falling in specific spot in Shadowmoon

I have had this happen twice in short order in the same place in Eventide Bay and it was as I was going off of a small drop and as i fell it disconnected me. The first time it happened I was on my tundra mammoth and after doing the self-service move to the GY at the garrison, I suspected it might have been related to my tundra mammoths vendors so I put it away and used my dreadstead instead. I didnt really seek out taking the same route, it just happened to be the path around a hill and toward my next quest objective and ended up in the same space and got disconnected again on my dreadstead. I reconnected again and tried to dismount in case it was mount related, still got disconnected but the next time I logged in I was already dismounted and same error. I tried to self-service move again but see that I am now in a 4 hour window that I need to wait for. I have exited the game completely and tried again but same error. I tried logging into another character on this server and that one is fine and tried having him send a single copper in mail to see if I could make the character “dirty” and that might change something and this also had no effect. I was able to get a screenshot of the exact location where the error occurred as well.

The WoW team will not see your feedback in the Bnet forum. Please post in the WoW Bug Report forum: