WoW stuck initializing

I know this is a topic already discussed, but nothing is helping. I came back today wanting to get back into the game and it has been stuck on “Initializing (2203058)” sometimes it stops but then goes back to those same files. It later gives me an error code telling me to restart the launcher/computer.

I have tried this and it just repeats the process. I have tried disabling firewalls and whitelisting and WoW. I’ve made sure its not my wifi, and ive had no issue installing the game previously. I made sure to delete any old Battle net/Blizzard files and ive tried reinstalling the launcher. I heard switching the launcher to BETA helps but when i go to switch, it just says there arent any beta features to test right now.

Please please please if someone knows how to fix this i need to know. I will try installing on a different computer on a later date, but i dont want this to just be something i have to accept and never be able to play WoW on my own PC.

1 Like

I am also having this same problem. Mine is stuck on Initializing (452/452 bytes) and just doesnt budge. Tried restarting deleting cache folder restarting comp. Nothing is working helllpppp. Was working fine everyday im on just today it wont complete update.

mine aswell starting downloading the game a minute ago but has gone back to the initializing.

I’m having the same issue. Won’t move beyond initializing.

Happening to me as well. Was looking forward to returning to the game. Darn.


Switching to the Beta client seems to have worked for me.

Settings > Beta

Thanks for the advice, I will try it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.