WotLK Won’t Update or Re-Install - I've tried everything

My WotLK Classic is stuck in a weird loop where it says it needs to update. I click update and it gives me the error code BLZBNTAGT00000BB8. I tried resetting my WiFi, tried to update using my phone data as a hotspot, firewalls turned off, restarting my computer, scan and repair, deleting addons, uninstalling BattleNet, uninstalling WotLK, uninstalling WoW Classic and I even deleted the classic and classic era folders (but these keep reappearing when I open BattleNet).

Now when I open BattleNet it sill tells me that I need to update even though I don’t have it installed anymore. When I try installing it just says Whoops!! Looks like something broke.

I was playing it fine in the morning yesterday and when I went to try again later in the evening it just simply doesn’t work for some reason, I’ve looked through forums and can’t find any solution that works. I’ve been playing it fine since pre patch started so I don’t think my MacOS version is the issue.

I’ve sent in a support request with files attached and I have no reply.



BLZBNTAGT00000BB8 is a generic error that means the Blizzard Desktop Application is unable to complete it’s assigned task and it doesn’t know why.

The typical causes are going to be network/connection related, corrupt desktop application/client specific or due to some sort of software/permission conflict.

The following steps should help:

Try doing an extended power cycle on your system. Turn off all devices including the modem. Wait 30 minutes, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

You can try switching your DNS settings to use a free public DNS servers instead of your ISPs Servers:

We do not have individual steps for specific modems or routers so if you need assistance accessing or updating the devices, contact the device maker/provider.

If you have a separate Router and Modem, Please temporarily bypass the router and plug directly into your modem. We only need to do this to test the simplest possible setup and see if the issue is affected in any way so you do not need to keep this setup once we are done troubleshooting. You will need to reboot the entire network and PC to allow the modem to properly connect you to the internet. Once you are done testing just reconnect the router and reboot everything again.

In some cases there is a corrupt or misconfigured setting within the router or modem. We cannot say what that might be offhand but the easiest way to resolve these conflicts would be to factory reset the router and/or modem.

You may need to look up your specific model for the steps on how to do this and in some rare cases you may need to have this done by the ISP. Feel free to reach out to them for assistance if necessary.

Let’s manually clear the Battlenet Desktop Application and all supporting data from the system. This will not remove existing game clients.

  1. Open file explorer/file manager (Right Click Windows Start)
  2. Navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  3. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  4. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  5. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  6. Empty the recycle bin.
  7. Now reinstall the app to the C: Drive.

Try running your system in selective startup mode: https://battle.net/support/article/200483

Create a new administrator account: Creating a New Administrator Account - Blizzard Support

Once the account is created, shut down the computer, wait 60 seconds, restart, log into the new profile and try the app/client.

Hi Kershew

I’ve tried resetting the modem, resetting my computer, switching DNS settings, uninstalling BattleNet multiple times, scan and repair multiple times, uninstalling and re installed both Classic Wow and Classic WotLK and it still doesn’t work.

I even uninstalled Retail WoW just to see what happens and that re installed perfectly fine with no issues. However every time I open BattleNet… WotLK and Classic starts an update, get stuck saying initialising, then says Whoops! Looks like something broke.

I’m on a Mac and my connection is working perfectly fine for everything else and it can update other games like Diablo or Retail WoW with no problem.

I’ve sent in multiple support requests and nobody is replying so could you please let me know how to fix this?

1 Like

bro facts im YouTuber verified and i cant even stream

1 Like

I’ve deleted all of the BattleNet files from my Mac ApplicationSupport folder, deleted the application and reinstalled BattleNet again.

WotLK and Classic Wow started to “reclaim space” and it gave me the option to Play. When I click it, the game fails to load and it now gives me this message:
ERROR #154 (0x8510009a)

When I click check for updates it says WotLK IS UP TO DATE.

Scan and repair doesn’t help. It just gives the same error message.

Closed BattleNet, reopened, WotLK has started an update even though it is fully up to date. I click Update. Then it gives me the same error code BLZBNTAGT00000BB8 from the beginning

1 Like

i’m in the exact same situation since last patch. i got around it at first by opening another wow client first and the update option would change to play and i could log in that way but now when i do that, all realms are red and say incompatible. this has happened to me before when classic first came out and i did not get any help so had to stop playing. now the same thing happening in wotlk. words cannot describe how frustrating this is because i know blizzard will not help, more than likely because they dont know how to help and 1 or 2 people dont matter to them in the long run

Having the same problem, stop blaming it on our end! It worked fine now it doesn’t!

Just fix it!

1 Like

It’s not Client side. Never is Never was. them saying “Restart” Or “delete and change file priority” proves how much they don’t know their own system. best you can do as I am is re-evaluated this company and see if you’ll stay. after 1 week if this problem hasn’t been fixed the company can stay in it’s dormant mode and i’ll be switching back to Valve


I solved this by uninstalling through battle.net app and delete the whole classic folder. Then when installing, choose some other directory than it is/was installed in. When I did that I could install the game.

1 Like

After being completely unable to do anything (update, scan and repair, uninstall, install, nothing), I hard deleted WoW Classic, and followed the steps here Deleting Battle.net Files - Blizzard Support to delete the battle.net files. After I did that, I couldn’t install to the same location, then I’d have the same problem, so as Qtii said I installed to a different location, and that did the trick.

Blizzard doesn`t care at all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.