World of Warcraft download stuck on "Initializing..."

The pre-expansion download for WoW Dragonflight does not start and is stuck at the “Initializing…” phase for hours.
I have tried restarting my PC as well as the application but to no avail.
Urgent support is required, as the servers seem not to be responding.

Note: keep in mind that being WoW a (costly) subscription-based game, the customers have great expectations on the quality of the service provided. Unfortunately, these expectations do not match the reality and it is not acceptable to have no announcement from Blizzard in this regard.


Im getting the same message. Then after a good while it says it can not connect to my internet. All my other apps are working perfectly fine. I’m sure its not my internet.


Same problem. Tried to re-install the battlenet launcher which is making literally zero progress. Pretty clear this is on their end


The same here… initialization all the time :frowning: Repair does not work because it forces an update

I have tried everything from re installing, restarting, scan and repair. Nothing seems to be working.

1 Like

I got the same issue what’s worse I Uninstalled the App and games now I am stuck here for 3 hr here 0%%%% for updating what do I do?

I’m having the same issues… has anyone else’s started working? I’ve been here for 55mins trying all sorts of advance from website but glad I didn’t uninstall it. thank God!

Downloading the new Nvidia drivers fixed this issue for me.