WC2 BNE - Ports forwarded, still wont connect

So I’ve just purchased and installed the WC2 release. I have reserved a static IP for my PC in my router and I have forwarded 6112-6119 for both TCP and UDP. I was able to create a new account and log in but no matter what I do, I am still getting the error screen in game saying:

“Your internet connection is either very poor or is not processing UDP packets through 6112. You will be able to chat but not play games.”

Is there an issue with the server or the game? I have done everything I can on my side and this is very frustrating.

Side note - Why the hell did they release the actual old game without updating it at all? Couldn’t we at a bare minimum, have gotten an updated interface for connecting online? I mean I appreciate the nostalgia, but I could have done without the old and horrible 1990’s era connection issues.

1 Like

Is this happening just now with your first attempt to log in to battlenet?

If so, minimize your windows and look for a Windows connection permission dialogue that you need to address.

I’ve reset the PC and loaded the game up… I don’t get any of those windows pop up and I’m still getting the same error when trying to connect to Battlenet. To be fair I can’t remember if one of those windows did come up when the game first started, but I normally accept them when I see them.

I turned off all windows firewalls and tried again to see if it would fix it. Still getting the same error message, so I don’t believe its a windows firewall permission issue.

Any other ideas?

Just take your internet cable plug it inside your main port to your wall , plug it out of the router and you dont need any opening ports . for the times you going to play warcraft 2 its a fix and u can host games!

The IP version doesn’t matter. I’m using IPv6 to my ISP and I play multiplayer.

It’s one’s router that need the ports forwarded, and a simple home-use router will use IPv4 for its connected devices.

Assuming you have a usual home network setup, this might be worth trying once just to see if it works. (I’d be curious.) If it does work, then it isolates the router or its settings as the problem.

To clarify, just remove the router from the chain by plugging your computer directly to the modem. (You won’t need to change anything with the wall port or its cable).
Just make sure to restart your comp after changing the connections around.

This is just a test to help rule in/out the router as the problem. It’s not recommended that you play the game this way due to bypassing the security that a router provides.

I got opened ports and I cant play it, but I dont have IPV4 and Im not using VPN

it works 100% and yes i got home network setup.

Between me and my ISP, I don’t either. So that’s not a factor.

Keep in mind that if your router is using DHCP (which is usually set as default), you may need to set your gaming computer to a static IP, then make sure the ports are fowarded to that staic IP.

I was responding to Shenzindo as something they could try to troubleshoot.
Sorry about the confusion. :slight_smile:

Ok so just to be sure, I’ve reset everything and got the Windows connection permission pop up to request permission again. So now that’s definitely fixed. Static IP is confirmed. Ports are forwarded.

I am still getting the same error when trying to log into Battlenet… is there any solution here?

Quick clarification:

The UDP/Port 6112 popup error? Or the update that fails and repeats over and over error?

Yes the port error pop up in game. Everything else is working, I just can’t get on to Battlenet. I’ve done my best to confirm everything is as it should be now, but still not working.

I don’t have much left in terms of suggestions.

One elimination step you can try just to rule in/out the router is to bypass your router:

Temporarily plug your computer directly into the modem, restart your computer, then try connecting to Battlenet again. If the UDP error goes away, that at least points to the router being a jerk.

I don’t recommend doing this to play the game. Routers provide another level of security that you don’t want to bypass for extended periods.

Outside of that, you may want to see if Bliz TS has any other suggestions. If you do contact TS, be sure to include what you have tried so far. (Make the explanation concise. The longer and more convoluted it it, the more likely it will confuse the TS agent).

I can try and help in about 8 hrs… no promises on solutions. But ill try.
Hit me up on discord @Maxx444

Im getting the same error and my ports are open for UDP/TCP on my router. Something weird may be going on

A couple things to watch out for are:

Forwarded ports can only be sent to one IP, meaning only one device on the network. None of the other devices on the network will run the game properly. So, be sure to forward the ports to the IP (device) you plan to play on.

If your router is set to DHCP, (usually is by default) a device’s IP could change with time. If the device you play on changes IP, the game will throw the UDP/port error again. If this happens, you may need to set your gaming computer to a static IP so that it doesn’t change.

Lastly, watch out for 3rd party firewalls and antimalware apps. They could potentially get in the way even if the router ports are forwarded. For example, Windows comes with a firewall. If it’s active, people may need to allow the game through it.

Don’t forget to call your ISP and request to remove your connection from IPV4 NAT / CGNAT.
I had problems with that too, I forwarded the ports, even tried the DMZ but nothing worked. Then I called my ISP, which here in Brazil I use Claro/NET, they removed my connection from IPV4 NAT / CGNAT, it took around 5 minutes. My connection dropped for around 1 minute, then after this 1 minute it came back.

Then I connected to Battle.net normally being able to chat and play.

Modern firewalls block communication for this game. I had the same problem, all you need to do is allow communication in your firewall (Windows, ESET, or whatever internet security you use) for TCP/UDP.

I set that rule, and it works flawlessly.

2 Likes

I just want to highlight what koreymac3288 pointed out above.

There other firewalls besides the one in a router. Windows comes with one, many antimalware suites come with one, and there’s other possible sources as well. They can all interfere with connectivity as well.