Was working yesterday but not today

Multiplayer War2BNE was working yesterday from the bnet launcher/server.
Today it wont let me past the login screen. Says incorrect password and losses connection with boot to network menu???
So I uninstalled and reinstalled… wont even load, gives me Direct Draw Error.
Can connect fine with GoG install + gog cdkey… not Gog+ bnet launcher cdkey. Same thing happens as above, incorrect pw and boot to menu.
I can only assume we are having issues with the authentication system?

To clarify, this is a generic discussion forum. No Tech Support Agents man this forum.

  1. Post in the Legacy Games Technical Support forum, or
  2. Submit a Technical Support Ticket for 1-on-1 assistance.
1 Like

you didnt happen to install war3 reforged did you?

i had the same problem, war2 working, then didnt work. only thing changed was installing war3 reforged.

Mine has done the same thing from time to time, and I have never played War3 Reforged. I stopped playing War3 soon after it came out, when I realized how terrible multiplayer was.

Hey Maxx444,

Was the yesterday when you created the account (created the password)? And, did you do only one play session?
And then today, you tried to log in for the second time and it said it was the wrong password?

I’ve had my account for a couple years or so, or for however long I’ve had it on GOG, and it told me wrong password. And then eventually it just randomly worked again. And then sometimes it decides to stop working again. It is on and off.

This is the same account I made with my gog install and played about 200games with.

I have a couple of hunches.
1- I cant port forward at work and the bnet version doesnt authenticate because of this. Gog version will and allow you to connect with the d/c unplugged icon.
2- I have conflicts because of multiple war2 versions installed in different folders. … maybe registry side. But clean install / bnet launch only should fix this. Which it didnt… ???

IDK - but i can play with Gog version and launch from anywhere with it. Just not bnet launcher.
I put in a ticket, we will see if the powers that be get back to me. I hope so. Love the game.

Wish this was the case Taylor. Tried again tonight, same issues.

Hey Maxx444,

Thought I’d let you know about this:

Not that it helps, but at least it sounds like it’s on Bliz’s end, not ours.

1 Like

TY for the update. Appreciate it.

I was able to log into Battlenet again a couple hours ago. Is it working for you again?

1 Like

Checked just now. Works again! Thanks for keeping us updated @Leviathan.