Warcraft 2 bne edition won't load

I just bought this game and I have tried everything I can think of to get it to run. It just gives me an error that says it has stopped working and I have to click end program. Tried to install the supposed patch on here but no luck. I have tried to run as administrator and nothing. Also tried tech support and they were no help either. Any help would be greatly appreciated. Thank you

Hey RubyRhino,

Unfortunately, those old games are being sold “as is” meaning they are not updated, remastered, etc. So they will have issues with modern systems.

That said, what you’re experiencing is not the usual issues that most people run into with these old games, so I’m not to sure what will fix it for you.

However, what you can try is buying the game from GoG. See here. It’s the exact same game, however GoG updates it to run on modern systems. If you buy it there and it works, you can refund the Bliz version (within 14 days of purchase).

Appreciate the reply and link. I will try the one you suggested. Thanks again.