Update agent stuck on update

The battle.net client bugged out and it only showed me my friends list. I tried re-installing, deleting everything associated with BNet in temp, appdata, etc, restarting and updating my drivers, re-installing Bnet, now i am stuck on installation, and the bar is just stuck, saying updating bnet update agent and thats it. After a few minutes it throws an error and i can’t even install bnet now…

7 Likes

There could be some bad cached data on the network, or left over from the client, or there could be some sort of software/permission issue happening.

Try doing an extended power cycle on your system. Turn off all devices including the modem. Wait 30 minutes, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

You can try switching your DNS settings to use a free public DNS servers instead of your ISPs Servers:

We do not have individual steps for specific modems or routers so if you need assistance accessing or updating the devices, contact the device maker/provider.

If you have a separate Router and Modem, Please temporarily bypass the router and plug directly into your modem. We only need to do this to test the simplest possible setup and see if the issue is affected in any way so you do not need to keep this setup once we are done troubleshooting. You will need to reboot the entire network and PC to allow the modem to properly connect you to the internet. Once you are done testing just reconnect the router and reboot everything again.

In some cases there is a corrupt or misconfigured setting within the router or modem. We cannot say what that might be offhand but the easiest way to resolve these conflicts would be to factory reset the router and/or modem.

You may need to look up your specific model for the steps on how to do this and in some rare cases you may need to have this done by the ISP. Feel free to reach out to them for assistance if necessary.

Let’s manually clear the Battlenet Desktop Application and all supporting data from the system again. This will not remove existing game clients. do not skip any folders you may have done previously as we do not know the condition of any current data in them.

  1. Open file explorer/file manager (Right Click Windows Start)
  2. Navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  3. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  4. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  5. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  6. Empty the recycle bin.
  7. Now reinstall the app to the C: Drive.

Try running your system in selective startup mode: https://battle.net/support/article/200483

Create a new administrator account: Creating a New Administrator Account - Blizzard Support

Once the account is created, shut down the computer, wait 60 seconds, restart, log into the new profile and try the app/client.

If that does not solve the issue, go ahead and use the support button at the top of this page (then the contact support button) to submit a ticket and be sure to include the requested system files so the tech agents can dig through this and help you address the issue.

im having the same issue… but one day my battle net didnt open anything and went straight to (updating battle.net updated agent…) itll give me Getting the BLZBNTBTS0000005C error so i deleted everything and tried reinstalling … nothing happened it always tells me the same thing (updating battle.net updated agent…) i tried opening battle.net as an administrator … i even cleared all my battle.net/blizzard files from the WindowR command. what can i do??? i just wanna play overwatch dude

4 Likes

Another post about this…Sorry blizzard your copy/paste response on what to do does not work when battle.net is causing the issue.

i have the same issue. I have uninstalled and reinstalled everything as well.

This doesn’t work. Any other advice?

Reinstalling windows is the only thing I have not tried…and like anyone wants to do that to fix a battle.net issue.

Is it a problem with a new windows update??

Same issues here; only see BNet friends list. Additionally, I’m unable to load WoW Classic WotLK or D3 independently by going direct to their executable files. /facepalm

The issue developed for me on a Overwatch 2 update that got stuck on “initializing” and ended up with battle.net stuck trying to reinstall. Enough people have had the issue the only fix is something in battle.net needs fixed or some sort of uninstaller needs released to remove whatever is causing this.

I’ve tried doing everything on this list multiple times, Its only gotten me past the “Updating battlenet” but now is stuck on the actual battlenet installation, which is stuck on 1%.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.