Unauthorized Bad Credentials Error

Hey there, I am trying to get my API calls working again. I have a static web page that is calling D3 API endpoints to get the Act names and descriptions and it has randomly stopped working.

I went back and made the changes necessary when the APIs change a while back and it was working fine for… well… until I checked today and it wasn’t anymore. I assumed there was another change to how API calls are made so I have been trying to follow the curl steps for receiving a token but when I do I get this error: {"error":"unauthorized","error_description":"Bad credentials"}

I thought potentially there might have been something wrong with my secret so I generated a new one after after waiting the 10 minutes it said it might take I still get the same error. This was my attempt (obviously clientID and Secrect have my actual values in my request):
curl -u {clientID}:{ClientSerect} -d grant_type=client_credentials https://us.battle.net/oauth/token {"error":"unauthorized","error_description":"Bad credentials"}

Can y’all help me?

As far as I know there was no changes regarding credentials, the last API changes only affected World of Warcraft endpoints due to the current API migration.

Please try to use your credentials on the official API docs page and see if they work there. Post if they do so we can try other things later.

Tips to Fix the 401 Error

Look for Errors in the URL.
Clear Your Browser’s Cache.
Flush Your DNS.
Deactivate Your WordPress Plugins.
Check the WWW-Authenticate Header Response.

Rachel Gomez