Unable to run/update Diablo 4. Overwatch boots inconsistent

Installed D4 through GamePass yesterday. Had to reboot to get the game to run, but after that, no issues.
Today, cannot run game. Reboot does not fix. Deleting Battle.net tools folder does not fix. Managed to get it to see an update that was not coming before. Error BLZBNTAGT00001398 when attempting to update. Reboot does not fix. Wrote an exception into my antivirus to prevent it from blocking this application. Pointed my system DNS to use instead of my localhost. No change. The inconsistency of running games in Battle.Net is becoming frustrating.


I had the same issue - after deleting tools folder the battle.net app gave me a different error - BLZBNTBNA00000006 and the battle.net app was unresponsive.

First time I fixed it by completely reinstalling battle.net, which is not ideal.

Fixed it just now by completely closing xbox gamepass and battle.net apps (task manager end process etc.). I then started battle.net by itself and logged in with my email and password (didn’t select e.g. xbox gamepass icon) - it started fine and error mentioned above was cleared. Located the game - it did its little update and now it launched.

I hope this helps.


It helped me. Thank you.