Unable to Play WoW since Last Patch

Patch day comes and I try to play the game a couple days later. I open Battle.net and click the update key and I get the “whoops something broke error”. I follow the directions to uninstall and clear out Battle.net and remove it from the iMac. Re-install the Battle.net and then proceed with the update.

Once the update is complete I press the Play button to start and then I get a CAS initialization error: unknown error. So now I look up how to fix this, go through the steps for the iMac and try again and still getting the CAS error.

It is really disappointing, the game worked on Monday, you do an update, I am then unable to load the update, follow the extensive process to remove and re-install Battle.net, get the CAS error, follow the extensive process to try and fix that problem and still getting the CAS error.

Don’t try to send me to your garbage list of things to try, this needs to be fixed, I am tired of the problems with Blizzard and its updates and without some correction or remediation I will cancel my subscription I have had for 15 years and chose a more reliable game to spend my time on.


Same issue here as well.

Uninstalled everything! Go and install Dragonflight and get hung up. Install Hearthstone no problem! Install WOTLK, no probem. There is an issue with Dragonflight.

1 Like

Same thing. Could play for some time after Uninstall, but a new patch came, and now even Uninstall doesn’t help. Nothing actually helps, and I spend my precious time in empty tries to update and play. It says, “Whoops! Looks like something broke. Give it another shot.​” (BLZBNTAGT00000BB8) even during download now. Therefore, everything I tried led to more complications. At least I can launch WoW after Uninstall/Reinstall without the BN launcher.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.