Unable to launch battle net after install

I’ve installed the battle net onto my pc and it won’t run. It will show up as a background process after I’ve tried to run it. I’ve installed and uninstalled multiple times, cleared the cache, checked for updates, updated drivers, turned off all antivirus software and firewall protections. I’m running a msi b550 motherboard, amd ryzen 3700x, 16bg corsair ram and gigabyte 2070 super.

1 Like

same problem here, can’t play for months already;
specs ; b350m, ryzen 5 1600, 16gb hyperx and gtx 960

Same problem here - b550 mb, ryzen 5 3600x, rtx 3070, 16gb ram

I also tried clearing the cache/temp folders, my drivers are all up to date, I don’t have specific firewall problems, tried running as admin, tried reinstalling, tried running compatibility mode… driving me insane…

I saw an old post from a support dude that mentioned Web Companion by Lavasoft messes with Bnet… I know at some point that sht was installed on my PC but I’ve uninstalled it…

This is really annoying - I can’t play any games, isn’t it dumb to lock games behind a stupid app like that ?

Unplugging my USB DAC/AMP (speaker amp over USB) worked for me - the app immediately started!

Edit: In Device Manager, I simply disabled this culprit USB device under ‘Disk drives’ and this worked while I could still use the speakers