Unable to install Wow on latest software (13.4.1)

I know all you guys from US but I am from EU and it worked for me with US vpn, Just need to download ‘initializing files’ and then you can turn it off and download rest. Also using beta client

1 Like

Still no update? Its been 2 months jesus, still cant install.
@blizzard they completely stop giving s*it or there is simply something wrong with m1 computers.
anyone have a solid solution?

Make sure that you have set under Battle.net>Settings>Downloads the download limits to 99999 or something - select latest updates with tick mark and then provide the number.
Also make sure that you do not fail to put the password for notification which comes up in the background for 'Agent" and also in App Management in Mac Settings make sure that you have Agent and battle.net added with the radio button enabled.

I would also try putting Mac to sleep if all of the above didn’t help, for me MacBook started the installation properly after above options + closing the battle.net app with command+q and then putting it to sleep mode for 1 hour.

Hope that helps guys.


Just wanted to share that this was the thing that finally did the trick for me - I tried full install/reinstall of Battle.Net several times, changing to my starter edition account, trying to install classic first, putting it in beta client mode, any weird thing that worked for people. I also tried updating the permissions for developer tools, full disk access, files and folders, and the folder permissions directly. This was the first I saw anyone mention the App Management permissions, and changing that was what finally got it downloading/installing for me. Thank you! Hope it helps some other people too because I was feeling a little hopeless.


Yes! Thanks. The App Management settings and changing the download limit fixed this problem for me.

1 Like

It’s sad that this happens for Mac users with every update. I fondly remember when that wasn’t the case.

1 Like

This fixed the issue for me, thank you!

I am in the same boat as everyone else in this thread, encountered the same error (being unable to download and install WoW) on 3 DIFFERENT MODELS of Apple Silicon:

  • M1 Air
  • M1 Pro
  • M2 Pro

I am not going to bother you with the technical details of my troubleshooting (strace, ltrace, etc.) but I found the culprit and I was able to successfully install WoW on all 3 laptops.

Blizzard app → Settings → Downloads → Download Limits
Add restrictions on both Latest updates and on Pre-release Content and make sure to use some high number. After applying, use Activity Manager to kill off any running instances of Agent and child processes of Battle.net Helper. Start Battle.net app and resume the install - it will work.

For Blizzard Devs
The Agent binary is taking the “unset” network bandwidth limit as 0 which results in “division by zero”. I don’t think I need to tell you what this amounts to.

1 Like

Running into the same issue. When I check the log files under the “/Users/Shared/Battle.net/Agent/Agent.xxxx/Logs” folder and sort by latest updated, I see a log file ‘bc-{Timestamp}.log’. In it, there are lines that requests are failing:

[E 2023-12-23 19:34:29.0727] [tact] Loose file download failed for ‘c4add4a71e501f69733092f213874324’. Error (1): unknown failure
[E 2023-12-23 19:34:29.0727] [tact] Download request for b9933de5a009d5a3a277df1d2e0b8ddf(46280754, 881198) failed with HTTP code -1
[E 2023-12-23 19:34:29.0727] [tact] Loose file download failed for ‘cf47ab3a199d953e5f07fe6df50f6069’. Error (1): unknown failure

I’ve turned on the firewall and added the agent to my allow list. I’m not sure what else to try, and went through the troubleshooting steps.

Ran into the same thing trying to install on M1 running Ventura. I’m logged in as an admin; however, kept getting the error about not being able to install. I even tried just installing the Battle.net desktop application and it too failed with same error.
So I went into the harddrive application folder, library folder and application support folder and deleted all folders with Blizzard, Wow, Battlenet or any thing that resembled those.
I then tried again with the same results so back thru cleaning out everything. That is when I went to “Get Info” on the application folder and found that I could not give “everyone” full access even though I’m admin tells me I don’t have necessary permissions to do so…

SO I just created a whole new folder under my user called WOW. I set everyone full permissions on the folder (Read & Write) and when I launched the installer changed the location to that folder for install and wal-la it worked installed everything without issue.

Once it launched the BattleNet app and started the download for WOW I again made sure to point to that new folder where it proceeded to download the 600+ MB of data. Still installing so we shall see but wanted to share as it seems a lot of other Mac users having the same issues. Fully convinced it is Apple trying to save us from ourselves but when I want to make permission changes I need to be allowed to…

1 Like

I’ve just purchased an M3 16" MBP and it seems the whole internet connection at home breaks when I start battle net and try to download. needless to say I can not use the full potential of my ISP’s bandwidth and no matter how hard I try to set the DNS servers either in the router or on my mac it breaks all the time and causes small internetnet “outages” on all the machines connected to either wifi or cable. I have Unifi network at home and my macbook is connected via cable. on modem side I see packet drops… As I can not be 100% sure it’s not the ISP’s modem so that I’ve ordered a new modem. we’ll see but the network problems are happening only when battle net is open on my mac and is downloading. on my PC it works just fine. I have more apple devices. no matter which I open the battle net on it happens again… very annoying.

I’ve debugged the issue and it seems to be server-side.
The battle-net setup tries to access this url and it fails:

Dear Support, please kindly pass this on to your server team for them to resolve.


╰─ curl -v http://eu.patch.battle.net:1119/agent/bgdl\?nocache\=1708984606                                                               ─╯
*   Trying
* Connected to eu.patch.battle.net ( port 1119
> GET /agent/bgdl?nocache=1708984606 HTTP/1.1
> Host: eu.patch.battle.net:1119
> User-Agent: curl/8.4.0
> Accept: */*
< HTTP/1.1 404 Not Found
< Server: TACT Http Server/2.24.6532
< Content-Type: text/html
< Content-Length: 64
* Connection #0 to host eu.patch.battle.net left intact
Not Found: No matched data for selector 'v2/products/agent/bgdl'%
type or paste code here

coolReally cooollll maan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.