Unable to install the Bnet desktop app on Macbook M1

I tried to install the Bnet app on my fresh M1 Air, but everytime when i try to install it i got stuck with the Battle.net Update Agent stopped at 45%. I went through the forums for hours and tried every solution, but nothing worked… it is getting really frustrating that i’m not even able to install it on a Mac…

6 Likes

I have the same problem and tried every single possible solution too. This is very frustrating and unacceptable :frowning:

1 Like

Same Problem here.
Tried every single offered solution there is on the internet. Nothing.

FYI i created a ticket with every info that we’ve got, and got an answer for it.

It seems there’s an issue currently affecting the Battle.net app on Mac. Our team is aware of it and investigating.

So atleast it is in the investigation phase, hope they will fix it soon.

2 Likes

I had this issue ALL day today, and just got it working

From terminal execute: sudo ~/Downloads/Battle.net-Setup.app/Contents/MacOS/Battle.net-Setup

that worked for me.

Obviously if your setup.app is in a different folder besides ~/Downloads/ you will need to update the command above

2 Likes

This worked for me after a few hours of digging around! Thank you!

I did the same thing, it looked as if it was going to work, but then I got this: The application encountered an unexpected error.

This works to install the setup. But then fails when running the app with “another instance is already running” error

hey could you send me a record screen of how you did it bcs I’m struggling lmao

Everything is running for me, but I also now have to run Bnet the same way, no clue why.
sudo /Applications/Battle.net.app/Contents/MacOS/Battle.net.

This was all working fine 2 days ago, then just…stopped. oh well, at least it works now.
Reptilia, not sure about the another instance thing. In activity monitor, do you see any agent or battle.net running that you could force close?

cmd-Space opens your app search, just type terminal in there, then hit enter to open it. then copy past what I had in my first post into terminal and hit enter. you will have to put in your computer password. that should be it

When you say cmd-Space do you mean press all those keys? Im new to mac and not understand what you’re trying to say.

I’ve debugged the issue and it seems to be server-side.
The battle-net setup tries to access this url and it fails:
http://eu.patch.battle.net:1119/agent/bgdl?nocache=1708984606

Dear Support, please kindly pass this on to your server team for them to resolve.

DETAILS:

╰─ curl -v http://eu.patch.battle.net:1119/agent/bgdl\?nocache\=1708984606                                                               ─╯
*   Trying 37.244.28.22:1119...
* Connected to eu.patch.battle.net (37.244.28.22) port 1119
> GET /agent/bgdl?nocache=1708984606 HTTP/1.1
> Host: eu.patch.battle.net:1119
> User-Agent: curl/8.4.0
> Accept: */*
>
< HTTP/1.1 404 Not Found
< Server: TACT Http Server/2.24.6532
< Content-Type: text/html
< Content-Length: 64
<
* Connection #0 to host eu.patch.battle.net left intact
Not Found: No matched data for selector 'v2/products/agent/bgdl'%
type or paste code here

Worked great for me. Thank you very much!

This does not work on M3 chipped Macs – says wrong CPU type.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.