Too many attempts - permanently locked out

The password reset site was on the blink yesterday which led to a “too many attempts” lockout on my partner’s account. She can’t even login to lodge a support ticket. We’ve waited > 12 hours and the site is still telling us “too many attempts” when trying to unlock or do a password reset. Livechat in Australia has not opened on time, I assume due to COVID related issues, so I’m at my wits end up to get someone to look up her account and fix the issue. We have a linked authenticator, but not a linked SMS.

See similar issues reported here: Changing Password does not work

Have obviously tried: https://us.battle.net/support/en/article/20530

I have now been able to unlock the account and attempt to reset the password. I am able to

  1. enter the correct account
  2. enter the authenticator code ok
  3. complete the email code ok
  4. enter a new password that meets the requirements
    on submission it gives an unspecified “error” and the new password does not work

Hey there,

The best thing to do here is contact support to recover the other account. When submitting the ticket, please be sure to include the email address for the other account and specify in the ticket it is a recovery for a different account.

1 Like

Thanks - finally have a contact acknowledging the password reset has been broken (of course no alerts here so how are we to know). Unfortunately still broken as even >24h getting “too many attempts” error. Still no sign of “chat support”.

I’m unfortunately having the same problem right now.

I am having the same issue too and I can’t submit a ticket. :frowning:

Same issue. Can not submit a ticket via the normal way.

And when I submit my ID to submit a ticket, support keeps resetting the wrong account. This happened 5 times now.

Could you stop resetting random accounts of a person? And please just reset the one account that is not working?

Hey I had this same problem but it occurred to all of my alt accounts as well. I went on to chrome cleared my cookies and it immediately fixed everything and let me log in. I also have the authenticator and it sent a request I accepted and everything was fine.
Hope this helps.

1 Like

I love you! Saved my life :slight_smile:

In my case it was problem with IP, had to reset my router to obtain new IP and it was solved.

I just ran into the same problem. Tried resetting my password, clearing browser cookies/cache Etc. I ended up pausing my VPN connection and boom it worked lol