Stuck on Downloading new files

My battle.net app stopped working randomly so I decided to reinstall and now I’m stuck on downloading new files. I’ve tried almost every possible troubleshoot available. Please help.

4 Likes

This is generally caused by other software blocking the install. Ex: antivirus, dropbox, onedrive, etc.

I have the same issue.

I’ve tried closing everything else. Still the same result.

I’ve had the exact same issue for half a year, and Blizz support have been of little help in resolving it.

I understand they can only advise a few things, but each one has failed and they eventually give up and say to contact Microsoft.

Surely if this is a more widespread issue, it’s an issue with the launcher and not people’s systems?

Your ISP or one of their routing partners may be blocking large downloads to conserve bandwidth for other users in your area. Try using an alternative connection, like a VPN, to complete the download.

Hello. How do I use different VPN?

Thank you,
David

Unfortunately, VPN setup is not something we can assist with on the forum.

vpn will in no way help with this

1 Like

It’s not an internet issue. I tried everything on my main PC from switching to another internet to shutting down all unnecessary applications but nothing helped. I only got it to work by installing battle.net on my tablet (using the same internet btw) and then copying the whole folder over to my PC.

My only guess is that I somehow screwed up the registry by manually deleting the battle.net folder after uninstalling the program, but that is what the uninstaller asks you to do at the very end, so it seems weird that it would break the reinstall process.

Hi guys, had the same problem and just found out it was the router firewall blocking the download. It worked the moment I disabled it. Good luck!

Hey Guys! am also facing the same problem, can anyone help me pls

The resolution is to disable your Antivirus and close the download and reopen the install file as well as disable your vpn after that you should be able to finish the download.

Having the same problem here ,tried all methods found on the internet and still not working :rofl: