Stuck on Battlenet update agent solution

HI ive been working tirelessly to figure out the issue and i finally got it, there are programs that are running in your computer processes that stop the update agent from updating per say, the process that was stopping it for me was something called Gajin Updater, soon as i stopped the process it let the setup go through and its updated all my games accordingly, i can play starcraft again.

if you cant find that gajin thing then it must be another program, you just have to stop non essential programs 1 by 1 until you figure out which 1 it is by using task manager and to add extra assurance i allowed battlenet to bypass my firewall security to make sure that wasnt it.

this method should work with anyone havng trouble getting battlenet started and updating again no problem.

please spread the word, this was incredibly frustrating to me not being able to play with my friends and im sure its plagued alot of other players too.

2 Likes

I think blizzard should just fix their incompetent launcher system, i still have issues after two years of Uninstalling/ Reinstalling , Disabling Settings, and checking my Command prompt. If any user has to go to these extents to get their launcher to work properly, its not the user, its blizzard. They make billions a year and they need to start acting like it. As a blizzard consumer for decades i am extremely disappointed in the way they approach customers issues and their lack of commitment to fixing issues. I’ve never had an issue with any other launcher other than blizzard and i commonly see their Programs multiplying in my task manager.

5 Likes

Maybe 2 weeks ago I reinstalled Windows 10 and updated it to newest Win11…also all drivers are updated. I installed Battle net client and tried to install all games… I installed SC1 and SC2 and everything else was very slow download (5-10kb !!! ) I set download limit to 0…my internet connection iz 200/200.
Then I uninstalled BN client and, when I tried to install new one, nightmare started. “Updating Battle.net Update Agent” constantly. I tried every solutions from net/forum/youtube…deleted all files from 4 folders…turned AV off…FW off…DNS servers changed to google…tried clean admin account…compatibility mode…run as admin…everything ! And problems is still here.
Please fix this ! I paid for the games that I can’t play !

Desperately need help with my friends install, same thing is happening will not finish initializing, have tried ever guide on every thread in every forum I could find

Blizzard help me

I hope this works for me as well. Been too many tiresome days/nights trying to figure this crud out.
BTW - Gaijin is another gamer platform like Steam. Thought you may want to know. Off to try your solution. Good luck all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.