Streaming Error WOW51900322 on Main Character

I was on my main character in retail and went to the mage tower in Stormwind to port to Boralus to turn in a quest. I was booted out of the game with this issue and could not get back in. Now hours later same issue - I’ve deleted cache and wtf, disabled addons, reset router, tried to repair the game but battle net throws an error. I also deleted program data folders for both and blizzard. My other characters log in without issue. Anyone have any ideas? If it’s a problem with just one character how do I fix it?


This forum is for technical support for the Battle.Net Desktop App, aka the “Launcher”.

There is some troubleshooting you can try here; blue coloured words are link to additional information:

If you’ve tried all that, or if the troubleshooting does not solve the issue, you should post on the WoW Technical Support forum, not here.

Best of luck in your games !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.