StarCraft 1 graphics driver too old

Beginning today, after some sort of update, we can no longer play StarCraft 1 on our old laptop with HD 3000 integrated graphics. We get the following error message that prevents game launch: “The installed version of your graphics driver is old and will prevent Starcraft: Remastered from running properly…Visit starcraft.com/drivers for information on how to upgrade your graphics driver.”

There are no drivers at that link. We have standard windows 10 version 1909. The Intel website says there are no updated drivers.

Ironically, StarCraft II runs fine.

14 Likes

Hey,

I have a Intel HD 4400 graphics, and I have the same exact issue. The odd part is I can apparently run the new ‘PTR server’ but not the actual Starcraft server, so I know the driver isn’t an issue.

5 Likes

Hi.

Some minutes ago my friends and me got started to play SC 1 and one of them got the same message you mention. We cannot find a way to fix it, tried to updated but does not work. Someone else won’t play SC1 tonigh here. I hope BLIZZARD fix it soon

3 Likes

Hey folks,

Starcraft Remastered has its own forums over here. You can post either in the Technical Support forum or the General Discussion forum. With the update that just went out, the Devs over there would love to have this information.

5 Likes

Having the same problem here with SC original. Why does the message think we are playing Remastered?

4 Likes

Same problem here. Patch installed 15 minutes ago, now I can’t game. BTW, there is no updated driver for my hardware.

2 Likes

Same here. I have been playing for the past few months without any issue. Playing the original version not remastered and it says that… What is wrong??

3 Likes

same problem, i can’t play due to video :cry:

2 Likes

please help. i want to play sc 1. i dont have sc remastered and i have the same issue… the same message of drivers

1 Like

I am the original poster of this thread. I have the original and remastered versions. On the laptop with HD 3000 Intel integrated graphics, I get the error no matter how I try to launch the game, or whether I am logged in or not.

The game launches fine on my desktop (AMD Ryzen 2600X/NVIDIA GeForce GTX 1660).

As suggested by Leviathan, I have posted this on the StarCraft Remastered forum, as well:

3 Likes

hey, you can play Starcraft through test server now…
I think they did it intentionally… to make people play in the test server…

2 Likes

whats wrong with these people?? i want to play!! I paid to play this game now I cannot play?? I want my money back… am full karen over here… where is the manager!!!

7 Likes

Everything good till yesterday. I can’t play it any more because of the same issue… My drivers are old :frowning: . Now my friends are playing without me. Please fix it.

2 Likes

i fixed it uninstalling my integrated graphics driver. On Windows 10 -> Right click on Start Button -> Device Manager -> Display -> Right click on the driver and uninstall it. Try to play again. This will be reinstalled on next windows restart.

1 Like

Did you run into any errors? might try it myself, if its a short term fix

It doesn`t work on my computer TT

more ppl can not play it, plz SC1 fix it

Yeah same here friends. Graphics driver out of date error. I was playing Starcraft original and yea it says remastered on mine too. The test server works I had to install it but I had to make a new profile for the single player and could not load my saved games :’(

almost ppl have old driver, if SC1 want to replace, I think more ppl will not play sc1

i cannot play :frowning: i was fine playing everyday but some patch f. up the game :c